Gameshell won't power on

Just assembled it for the first time. When I plug it in the orange light on the mainboard comes on. pressing the power does nothing. I’ve disassembled and reassembled it a couple times and there’s no change. I’ve checked all the connections. I’ve re-flashed the OS with version 0.5 multiple times on different SD cards. I’ve tried it with different things plugged in and with the battery plugged in and not. I’ve tried it with the usb plugged in and not. the orange light stays on for several minutes and eventually shuts off but turns back on if I take the charging cable out and put it back in. There’s no other color led. just the orange one.


mine arrived a couple days ago and after the assembly it is doing the very same.
Today I had some time and disassembled and reassembled the entire device.
I also took out a multimeter and what I noticed is the the battery voltage was below 2.5 V which, I believe is too low. I am looking for a replacement battery as my first guess.

If anybody has a better idea please let me know.

Also is there a way to get it serviced?


Hey guys, if you need assistance, please email to

Thanks Alex,
I just emailed you!