clockworkPi

[SOLVED] GameShell suddenly stopped working


#1

My unit has stopped working. I turned on the unit Saturday and it worked fine. Last night, it didn’t power up. I tripled checked all of the wire connections, the microsd card placement, and even let it charge overnight, but still nothing. One thing I noticed is that the charging indicator light did not go on when I was charging the unit.

Any tips? Suggestions???


#2

Did you try your charger on other device? Or did you try another cable?

Also check the chargin port pins on the port and on the board if they are okay.


#3

Yes. All cables are plugged in and all in place inside the GS. I also tried different charging cables & bricks combos, and it still won’t charge or boot up.


#4

If you think it’s an issue with power you can use a multi-meter to test the “test points” on the board and compare them to the open documentation


#5

I’m not a maker nor a modder, so I don’t ave any equipment to test the GS that way.


#6

… I would recommend a little bit of knowhow prior to owning a game shell

Try holding the on button. I find if I disconnect the battery for any reason I have to hold the power button first boot


#7

I’ve tried holding on to the power button, and nothing. I’ve also hit the reset button, and nothing. I even reflashed the OS on a new microSD card to see if the card was the problem, and still nothing.
So either the cable connecting the batter to the main board is damaged or the battery is dead. Gonna keep trying.


#8

Will it power on with the USB connected? Does the LED on the back of the logic board light when USB is connected? You don’t need anything but the display connected to power it on with USB.


#9

No lights pop on when the USB cable is plugged in. I’ve tried different combinations of microUSb cables and power bricks, with no luck.


#10

As a side note, a multi-meter is good general purpose tool anyone should have in a tool box along with other basics like hammers and screwdrivers. I would encourage you to pick one up. You can even find them in hardware stores.


#11

Something similar happened to me, and it was the SD card, with wrong SD card it doesn’t charge and power on neither. Try this:


#12

Folks, the unit is working again. I followed some advise from a chess grand master and moved backward to solve this.

I re-assembled my GS step-by-step as when i first got it. I tried the different microSD cards I has flashed the image to with no luck. I got retro when I decided to flash the image onto a card using an older computer (running Windows 7). I popped that card into the GS, and KAPOW! it powered up! I tried the same thing with all of the other cards I had and they all booted up with no problems.

I don’t know if the whole problem was due to 1) my computer, 2) Windows 10 on my PC (which I recently updated), 3) the Etcher I was using, 4) the microSD card adapter, or 5) the image of ClockWorkOS I had.

P.S. - the chess grandmaster I was referring to was Maurice Ashley. Look up his TED-Ed video.


#13

Thanks for the advise. I’ve worked with desktops most of my life, DIY building my last 3 gaming rigs. After this experience, I definitely want more hands-on know-how on micro-circuitry.


#14

Glad you could get it to work!