gPSP saves 128k help


#1

Any way to add 128k saves to the GPSP emulator? I’m playing a rom hack and i get this when I boot up, and because of it I can’t save the game (save states do work tho) Saving does work with mGBA but it’s laggy. gPSP runs perfect speed… I just need to change flash memory to 128k within the emulator and don’t know how to do it in retroarch.


#2

Sorry if this is off-topic. How did you get gPSP to work? I have tried with the BIOS and setting the system folder in Retroarch and it always crashes before loading a game.

Thanks man!


#3

Honesstly man… I haven’t run into any issues with any of the emulators (MSX is an exception but its use is rare) so I don’t really know where to begin to help you… it could be an issue with the BIOS file you have. When I get home to my device I will go through some file systems and try to help you out!

As for my issue, I seem to be on the right path, but can’t put my finger on it. gPSP and a lot of other emulators can load game-specific overrides… I know how to change the flash memory in the override… I just don’t know how to get retroarch or the core to actually READ from the file.

I’ve tried “game_name.txt” in the same folder as “game_name.gba” and it wont work.


#4

That’s so wierd. I’ve downloaded Retroarch as per the guide, and I’ve done everything to make gPSP work and it still crashes. Every other emulator runs fine, including mGBA, although this one has slowdowns that make games unplayable. When I get home later I will post a video!


#5

i tried to edit stuff and ended up wrecking my gpsp_libretro.so (forgot to backup) now the latest one on the website http://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest/gpsp_libretro.so.zip just crashes lol


#6

Maybe you had an older one that worked? Does it crash after loading a game without saying anything at all like mine?


#7

yeah same issue man im gonna go get an odler version and check ill let u know