Headphone mic (TRRS) not working

Hello everyone, hello Clockwork,

I’ve been trying to use a pair of headphones with built-in mic (TRRS) on my Devterm A06, but I can’t get any input from them.

Alsa seems to detect the microphone, as some config is applied: some values change in alsamixer as soon as I connect the headphones, and an input device is showing up on pipewire. But no audio input is detected whatsoever.

I tried to modify some settings in alsamixer, tried to amplify the mic input, but it didn’t help. I use my Devterm as a daily and would love to be able to make calls through it.

I’m not using Clockwork’s Armbian, so maybe this issue is just related to me. Does anyone use headphones mics here?

1 Like

I just tried it on mine (running Manjaro). Output works, but nary a blip on the input meter no matter what settings I change ¯\_(ツ)_/¯

Your best bet would be a cheapo USB audio dongle or USB headset. Or perhaps even Bluetooth headset if you’re feeling adventurous.

Pretty sure I read somewhere the jack isn’t physically wired to anything…

Devterm’s specs shows the microphone input capabilities:


Motherboard’s schematics shows three mic pins (MICBIAS, MICP, MICN) connected to GPIOs (124, 126 and 128). I’m no expert but I guess there’s something here. Is it exploitable?



1 Like