Hirsute went offline late July 2022, how to manage?


maybe it could be related to the situation that apt.armbian.com is currently returning http error 500 all the time?

I believe that this is the issue that I am facing, as a lot of the repos give that error

It’s certainly odd that we are using the same computer and same image file, doing the same thing and getting different results. Nonetheless, I waited, and it eventually completed. It took all night and finished some time today. It might have finished earlier but there were about a dozen instances where it stopped to say that there was a file in the new updated version that differed from the old version and did I want to use the new or keep the old (funny that the default was to keep the old – I would have thought the default would be to use the new, since it is an upgrade, after all). In other words, I did the opposite of arru in post #5 and used the new version of the file in question.

Anyway, it finished, so this is to say that it @arru’s description worked for me; but now I guess I start all over since @guu posted a new release today (DevTerm_A04_v0.2c.img.7z) in post #21.

Just about to give it a try, just one note, it would be easier if it were compressed as .bz2 like the rest of the images rather than .7z.

OK link updated
it is bz2 now


The out of the box image seems to work, printer works etc. but the moment you try to do an apt update && apt upgrade it will upgrade without error but then refuse to turn on again after being shut down (backlight comes on but no screen output).
I’ve already written the image 4 times in case it was something I missed with the replacement of config files during the upgrade but it seems entirely broken no matter what options I choose.
The image also still has the issue with the top pixel row of the screen showing at the bottom.

did you use the 7z version ?

I tried with both 7z (which I had to extract first for Balena Etcher) and bz2 which works natively with it.
Both images work fine on boot and both restore from shutdown, it is just when performing updates that causes them to break.

There is also something funky going on with the SSH stuff. It still shows a readme on boot about ssh being disabled but:
/etc/ssh/sshd_not_to_be_run does not exist and systemctl status sshd shows that ssh.service is running.

I haven’t tried @guu’s v0.2c version yet, after seeing the problems mentioned in the most recent posts, so I’m still on the v0.1a image which seems to be working (though I’ve not tried much yet). But really what I wanted to ask about was this comment from @arru about re-enabling these sources. They all say that they have been disabled on upgrade to jammy. So they need to be put back in spite of this?

Caveat: this is my own, quite amateurish interpretation of the desired post-upgrade configuration:

/etc/apt/source-list.d/clockworkpi.list enable because it supplies ClockworkPi-specific packages with hardware support

/etc/apt/source-list.d/armbian.list keep disabled because there is no native support for A04 in Armbian, yet. A06 should be supported, but I can’t confirm it myself

others in this directory will depend on exactly what you have installed previously (if any). My tip is to change those from hirsute to jammy and try if that works, keep disabled if there are errors.

1 Like

upgrade issue fixed in DevTerm_A04_v0.2e.img.bz2

I forgot to mask kernel to prevent from upgrading

so that is why after upgrade ,can not boot


hey, registered here just so that I can get some clarification about the image @guu 's posted.

Is it normal for the balenaetcher to be that long? or something’s wrong with the .bz2 image posted?

EDIT: tried with the 0.1a old image to see if the problem’s on my laptop’s usb but that one’s fine, took only 20 minutes tops.

456m is too long
0.2mb/s is too slow for USB device

but the size of the image seems ok

I dont know where is the problem , guess the USB port issue

I don’t have this problem at all, the 0.2d image flashes in about 10 mins or so for me with my laptop’s inbuild SD card slot. Not tried e yet.

@guu I’ve been running the d image for the last week or so. It has been very stable and everything works so far. What has been changed between d and e?


I had several problems getting the file to finish downloading from Mega, it would sit at 100% but not finish past that point. Finally worked on a different computer this morning.

Tried to flash it to a card and had the same problem with etcher, it basically just sat there. Cancelled, ran etcher as Admin, same issue. Used 7zip to unzip it to an .img file. Etcher then blaster the .img onto my card very quickly and I’ve been configuring things for about an hour.


Never occured to me to extract the .bz2 file in the first place!

I can attest now that after extracting the file and went with balenaetcher, all’s smooth sailing! thanks!

also if @guu would be so kind as to explain the differences between d and e ie: any problem regarding the screen and HDMI have been resolved here?

I double checked the d image, seems that the d image I forgot to mask two packages

linux-dtb-current-rockchip64 and linux-image-current-rockchip64

and this will lead apt upgrade fail to boot

please check your system to see if those two packages have been masked by

sudo dpkg --get-selections | grep hold

if not ,no packages
then use

sudo apt-mark hold linux-dtb-current-rockchip64
sudo apt-mark hold linux-image-current-rockchip64

to do the mask job

HDMI on a04 is hard

but cpi is working on it

I will upgrade the kernel package as soon as the HDMI got fix

1 Like

Both of those are already being held on my system and I’ve been using apt upgrade without any issues.

Not sure if it is related to the new image or not but my DevTerm ran out of power and shut itself off and now when it boots sys/class/backlight/backlight@0/brightness is always set to 1 which isn’t easy to use meaning I have to set it higher each time it boots.

so now everytime DT boots, the screen is like totally black ?

and you have to set /sys/class/backlight/backlight@0/brightness to see the content ?