Hirsute went offline late July 2022, how to manage?


So trying to brainstorm here, several users here have already noted that Ubuntu Hirsute was old hat already at the launch of DevTerm, now, as far as I understand, it’s been EOL’d completely which means that apt basically does not work anymore (and there are security implications as well).

Since around July 24th 2022, apt fails with
ports.ubuntu.com … no longer has a release file

I’ve tried the advice to replace ports.ubuntu.com with old-releases.ubuntu.com in /etc/apt/sources.list but this did not work, as maybe expected since it’s using ports, not archive.ubuntu.com.

Has anyone else run into this, or is everybody running custom builds by now, or is there some other solution that my noobness is foreseeing?

Running A04, although that should not matter in particular with this problem, no?

(BTW does this not mean that the bundled DevTerm OS 0.1 will be broken right from unboxing?)


I am still on hirsute too and am having this issue. I’ve been looking for a fix!

You can edit the /etc/apt/sources.list and replace the URL to



1 Like

Thank you very much!

Back on the flip side, this is what I had to do to resolve the apt problem (and upgrade to the latest LTS Ubuntu, 22.04 Jammy Jellyfish):

Change entries in /etc/apt/sources.list to old-releases.ubuntu.com/ubuntu
(not adding /ubuntu at the end was the mistake I made earlier, that caused this change to fail)

Deal with armbian-zsh dependency bug

This broken dependency was blocking my upgrade (and probably the reason I got stuck here in the first place). Solution:

sudo apt purge armbian-zsh && sudo apt install armbian-zsh

prepare and do upgrade

sudo apt update

sudo apt upgrade -y

sudo do-release-upgrade

(note the last command is not a verb in apt, as is incorrectly stated in some places)

Blocking processes

(run in another terminal, after prompting by the update manager)

pkill xlock

pkill xscreensaver

Then press OK

Configuration files

During the upgrade, I got prompted by the upgrade manager about the following config file contents (altered by clockwork Pi installation most likely). Looking thru them to the best of my abilities, I decided to keep all of them as is (default option). Not saying this is correct, but my DevTerm hasn’t halted and caught fire yet :slight_smile:

keep local /etc/ssh/sshd_config

You will later be asked to remove obsolete packages, which is what I did.

After restart

Re-enable third party sources:
/etc/apt/source-list.d/armbian.list (may need editing to point to new Ubuntu version)
and any others that you still need


Whole process took around 4 hours, including a lot of waiting and prompting for the config files as mentioned above.

In this case, the latest Ubuntu release also happened to be LTS (long term support) one, which means that you’ll get 5 years to upgrade, instead of 9 months. If the latest one is not an LTS release, there are ways to configure Ubuntu to only jump to the latest LTS, which you may or may not wish to do.

As I understand it, the OS image I started with, 0.1a, is still the latest available for download and presumably also the one that’s shipping with new DevTerms. So out of the box, to use APT again (and for other reasons including security), any new customer would have to go through the steps above.


Well. I am that lucky one getting a DevTerm finally delivered to me today and all apt operation fail right out of the box.

After reading this thread, I’m still a little confused. Is changing all entry of ports.ubuntu.com to old-releases.ubuntu.com will just solve it all?

Do I still need to upgrade release? and upgrade to what? Ubuntu 22.04 or armbian 22?

And as a zsh user, I had planty of plugin to stuff into this machine. So I’m also interested in what is this armbian-zsh thing you mentioned. Would be nice if you can point me to some page explaining it. Thanks.

Hi @leograyc , welcome to the community! (what a way to get thrown in there…)

I’ll try to answer each question:

  1. Yes, just replace all URLs to ubuntu.com in the source.list file with old-releases.ubuntu.com/ubuntu, making sure that /ubuntu has been added at the end of the URL as well

  2. yes, you should upgrade to a supported version since the old EOL ones don’t get security updates anymore. You can follow the path I took using the instructions above. About Armbian upgrade, that sounds like a good idea, I’ve held it off to make sure I don’t lose any ClockworkPI patches on the kernel and brick my DevTerm, until I figure out if that would be a problem…

  3. So some (all?) users have had a problem where upgrading the shipped version of armbian-zsh fails due to a missing dependency on some file with osx in the name (so clearly not an actual, needed dependency). Once you do the old-releases change you may or may not see this. If you do, just reinstall this package with the one-liner above and you’ll be fine. Unfixed, this won’t let you upgrade the ubuntu release.

Good luck!

I just got mine today, and yes all broken. First I had to update my pgp keys, as everything failed before the repos failed. Followed your directions and was able to update. Now I am in the middle of the upgrade, fingers crossed!

1 Like

It also tells me it auto disabled services, but I couldn’t tell which ones. Any ideas which ones I have to reenable?

Hmm, services eh? It will auto disable 3rd party repos in /etc/apt/source-list.d/ , see instructions for those above.

In my experience even as incomplete as it is (no printer support, slightly wonky power management) the Armbian 22 image is much “better” than the CPI one.

Thanks a lot for the clarification. Since this is a SD card driven device. I will actually try to setup another sd card with armbian 22 to play with.

1 Like

Seemed to just walk through the upgrade path when I did it a few weeks ago.

Yes, the upgrade seemed to go smoothly. Went directly to 22.04.1

No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 22.04.1 LTS
Release:	22.04
Codename:	jammy

And there is a list of services running now that has a few turned off still, although this may be on purpose:

 [ - ]  alsa-utils
 [ - ]  anacron
 [ + ]  apparmor
 [ + ]  apport
 [ + ]  bluetooth
 [ + ]  chrony
 [ - ]  console-setup.sh
 [ + ]  cpufrequtils
 [ + ]  cron
 [ + ]  cups
 [ + ]  dbus
 [ + ]  fake-hwclock
 [ + ]  haveged
 [ - ]  hostapd
 [ - ]  hwclock.sh
 [ + ]  ipsec
 [ + ]  kerneloops
 [ - ]  keyboard-setup.sh
 [ + ]  kmod
 [ + ]  lightdm
 [ + ]  loadcpufreq
 [ + ]  networking
 [ + ]  openvpn
 [ - ]  plymouth
 [ + ]  plymouth-log
 [ + ]  procps
 [ - ]  pulseaudio-enable-autospawn
 [ + ]  resolvconf
 [ - ]  rsync
 [ - ]  screen-cleanup
 [ + ]  smartmontools
 [ - ]  speech-dispatcher
 [ - ]  spice-vdagent
 [ - ]  ssh
 [ + ]  sysfsutils
 [ - ]  sysstat
 [ + ]  udev
 [ + ]  unattended-upgrades
 [ - ]  x11-common
 [ + ]  xl2tpd
1 Like

Thank you so much for detailing this, I was getting really frustrated in trying to get the thing to work properly (not overly familiar with Debian based distros) and this worked perfectly.

Yup, really annoying. The Clockwork team really needs to update their image on the website if nothing else. I imagine they might have a lot more frustrated people in the future who might not even see this forum post. I don’t think it is unreasonable to expect it to work out of the box without 5 hours worth of updates and patching.

Edit - spoke too soon. I was seeing if it would build a nodejs project and the whole system froze on me. I reset it by holding the power button but when it starts back up now it doesn’t seem to recognise the mouse or keyboard. The standard XFCE desktop shows up but you can’t interact with it. I saw this behaviour a lot with the stock image too and was hoping it was just related to it.
For the record I had restarted it a few times after the upgrade process and it worked fine.

Edit edit - I turned it off for a few mins, turned it on again and the mouse works again… I have no idea…


If the latest one is not an LTS release, there are ways to configure Ubuntu to only jump to the latest LTS, which you may or may not wish to do.

How do I achieve this?

I will want to perform these steps as well and it would be a really bad surprise if after 4 hours I find out that the version I got is not LTS.

I would really like to avoid having to repeat this.

To anyone doing this:
I highly recommend making a backup image of the SD card before.

Do we can expect that there will be an official updated OS image?

ETA: I found out that I should put Prompt=lts into /etc/update-manager/release-upgrades/.

But it says that if will not be effective if my current version is not an LTS.
So how to do it to have LTS unconditionally?
Is the current release an LTS?
How to check?

ETAA: I did this and the menu bar changed to whire :slight_smile:
also it is complaining about the one from /etc/apt/source-list.d/clockworkpi.list

so when I try to do this, I get an error saying:

pcilib: Cannot open /proc/bus/pci
lspci: Cannot find any working access method.

Any idea what I may be doing wrong? I made sure that I updated the URLs in my sources file.

Any idea what I may be doing wrong?

Nothing; keep waiting! I got the same thing (I’m doing this right now, as we “speak”) and I just let it sit. About 20 minutes after this lspci: Cannot find... message there was more activity, then it said it was about to start the upgrade and it could take several hours (it’s underway now).

So just leave it; I think you’re underway.

Here is the A04 os image with Armbian 22, LTS ,end at 2037

with all the stuff like previous os image


for A06


Ah, unfortunately mine will say that it can’t find a bunch of repos and then it says that it’s restoring the previous system state and does not do the upgrade. I am going to try the image that Guu posted!