How can I install, configure and run DOS games?

The gameshell OS IS Linux, and no that does not partly solve the issue

Has anyone got around to run DOSBox through RetroArch on the GS? Would love to hear some tips :slight_smile:

I installed DosBox:
sudo apt install dosbox

I changed at least these settings in ~/.dosbox/dosbox-0.74.conf:


Then I started the keymapper:
dosbox -startmapper

Then I mapped something like this:
key_space - Key i
key_lalt - Key j
key_ctrl - Key k
key_lshift - Key u

key_i - [blank]
key_j - [blank]
key_k - [blank]
key_u - [blank]

key_q - Key h
key_b - Key l
key_y - Key o
key_n - Key y

key_h - [blank]
key_l - [blank]
key_o - [blank]

Jazz Jackrabbit does not run very well, but other games like Commander Keen do:
dosbox ~/games/Jazz/JAZZ.EXE -exit -exit

1 Like

People who want to play Jazz Jackrabbit should not use DosBox anymore, but use these instructions.

Do you think something like this would work for Alien Carnage (Halloween Harry)? I have a whole bucket list of dos games from my childhood that I’d love to play on the GS. Some are less intense than others but most are like the one mentioned above. I’d love to play the old duke nukem!

I know the old Duke Nukem works through DosBox on the GameShell. I haven’t tried Alien Carnage yet, but I think I once bought it, so I can try it out.

I prefer to ditch DosBox and run stuff natively. You can find on this forum how to do that for Prince of Persia, Jazz Jackrabbit, Duke Nukem 3D, Commander Keen etc. but I haven’t found a way for the Duke Nukem 1.

Like I said, Duke Nukem 1 (and 2) do run on the GameShell through DosBox!

Yes. The game is actually freeware. I did not know that.

Oh hell yeah you just made my night! Totally going to try that this weekend. Bio menance and original Duke nukem here I come!

Finally got around to trying this out and I can’t get it to launch! It just crashes when I click the icon. . . Could you help me out? Here are the the commands I modified from Jazz Jack Rabbit to work for this:
mkdir aliencarnage
cd aliencarnage
chmod +x aliencarnage
chmod +x CARNAGE.EXE
echo /home/cpi/aliencarnage/CARNAGE.EXE > /home/cpi/apps/launcher/Menu/GameShell/
chmod +x /home/cpi/apps/launcher/Menu/GameShell/aliencarnage

Any help would be very much appreciated especially since it seems like you got it to run!!

Jazz Jackrabbit does not need DosBox if you run OpenJazz.

Alien Carnage and Duke Nukem 1 still need DosBox.

Install DosBox if you have not already:

sudo apt update && sudo apt install dosbox

Create a games directory for Alien Carnage:

mkdir -p /home/cpi/games/aliencarnage

Go to that directory:

cd /home/cpi/games/aliencarnage

Get the Alien Carnage zip:


Unzip it:


Create a menu link that utilizes DosBox:

echo 'dosbox ~/games/aliencarnage/CARNAGE.EXE -exit -exit' > /home/cpi/apps/launcher/Menu/GameShell/

Reboot and let me know if it runs.

After that I can help you to set the DosBox settings right for video and controls. The resolution will be wrong in the beginning!

Icon!?! I just installed looks sweet

I put chips challenge on there. Runs fine but I can’t quit it. Any pointers on how to SSH edit a config for a dosbox title? I’ve tried.

Maybe dosMapper will run?

Works! Thanks so much!! Yeah I messed with the .conf file for dos box to try to figure out the resolution and couldn’t get it. If you could let me know how to do it, that would be very much appreciated!!

OH wait… . . I saw you already said that stuff at the top of the thread.The dosbox -startmapper also can’t be run from an ssh session so I’m not sure how you launched that command from the GameShell. There was a brief screen for mapping up, down, left, right and thrust but nothing for changing weapons or stuff like that. Thanks again for helping out!!

In the dosbox config file (located in /home/cpi/.dosbox) change the full screen res to 320x240 and below that change output to opengl

In a section below that, change offset to true. (I think it’s offset. I’m not around my computer to check lol)

Because you launched DosBox, it created the folder .dosbox with in it dosbox-0.7.4.conf.

Here are my video settings: dosbox-0.74.conf

You are right. I cheated.

I installed DosBox on my (Linux) PC and created the file:

You can put that in your .dosbox directory. It uses the configuration I posted earlier.

I have not mapped the key_s to select Sound Blaster in Alien Carnage. Anyone selected Sound Blaster yet?

I use my for all my DosBox games.

When asked:
Are you sure you want to quit (Y/N)?
I press Shift-Y.

Does any have any interest in trying to get “The Oregon Trail” working with DosBox? Seems like it would be cool

Hi, can you share each of the Gameshell + Lightkey, buttons codes for DosBox?
Ex. X = Key18
Y = Key248…

If not, how can you figure which key does what and add it to the mapper file?
The reason I am asking this is, I want to add a jump key to your mapper file but can’t figure out each of the GameShell button corresponding codes…

Not sure if my question make sense. lol

here is SDL keycode for gameshell, yet never plug lightkey so don’t get them =)

#define ka 106 // j
#define kb 107 // k
#define kx 117 // u
#define ky 105 // i
#define kfna 104 // h
#define kfnb 108 // l
#define kfnx 121 // y
#define kfny 111 // o
#define kselect 32 // space
#define kfnselect 269 // -
#define kmenu 27 // escape
#define kfnmenu 8 // backspace
#define kstart 13  // return
#define kfnstart 270 // +
#define klk1 278 // home
#define klk2 280 // pageup
#define klk4 281 // pagedown
#define klk5 279 // end
#define kfnlk1 kfna
#define kfnlk2 kfnx
#define kfnlk4 kfny
#define kfnlk5 kfnb
#define kleft 276 // left
#define kup 273 // up
#define kright 275 // right
#define kdown 274 // down

for missing keys you may check
and compare them with