How do I install Pico-8 on a A06 DevTerm

Keep running into issues with the A06 DevTerm. I’m trying to get Pico-8 to work with it. But I just can’t seem to be able to execute it.

Doesn’t work in CLI. Doesn’t wok in GUI. :sob:

What am I doing wrong?

Is this a compatibility issue? I’ve downloaded the Raspberry version of Pico-8. Is that even the right one for the A06?

Try running ./pico8 :slight_smile: That directory isn’t in your PATH, so bash doesn’t know how to find it. Telling it the directory with ./ explicitly should work. (This isn’t devTerm specific, it’s true on any unix-like machine.)


pico8 is 32 bit ,and a06 is running 64bit
so maybe that is why can not run pico8

Good thinking but makes no difference :slightly_frowning_face:

Hmm, could be something like this. But I thought all of the DevTerms were 64bit? And isn‘t that backwards compatible? Can‘t I run in in some kind of legacy mode?

Maybe make the pico8 binary executable?

sudo chmod +x pico8

Then launch


Sadly, no. The executable flag is set correctly.

I think I was able to narrow it down to a 64/32 bit compatibility issue. The error message is just misleading. Explained in this thread:

The A06 DevTerm unit runs a 64 bit system (aarch64 ). The RPI DevTerm units run on 32 bits (armv7l). Which is why the RPI units can run the Pico-8 32bit build with no issues.

If anybody has ideas for a workaround I‘d love to hear them because I am thoroughly out of my league here. :sweat:

This is the reason I stick to Raspbian or Ubuntu 32bit server for now.
Possible solution could be runing in QEMU? I am not sure.
If I sucessfully install Raspian on VMware ESXi Fling (on Raspberry Pi 4), I could try to do the test.
(I am trying to install)

sudo dpkg --add-architecture armhf
sudo apt-get update
sudo apt install libudev1:armhf libsdl2-2.0-0:armhf
sudo reboot now
# After reboot

pulls on cigarette „Jackpot! I got in“

Thank you @guu ! You made my day!


@guu hanks for your post, I can run PICO-8 on Raspbian aarch64 easily.

PICO-8 on ESXi Fling:

1 Like

im getting the error: warning: Architecture armf not defined in architecture tables, ignored. The first time i put the command in i accidently typed armf, but have tried repeatedly with armhf to no avail with that same warning everytime. any help?

I am much more familiar with the command line now, and a little more aware of needing to type correctly. And i love the google. Pico-8 up and running!

1 Like

Hey all, PICO-8 version 0.2.4 came out today: PICO-8 0.2.4

It has native 64-bit Raspberry Pi builds! Just download the Raspberry Pi zip file from their site, unzip, and run pico8_64 on your DevTerm, no more hassles!

Confirmed. Works well. Needs to be executed from the CLI.

“Needs” is a strong word. You can always create your own .desktop file :slight_smile:

Edit: To be more helpful, here is the .desktop file I created for Pico-8, which I wrote to the path /usr/local/share/applications/pico8.desktop so it gets included in the menus:

[Desktop Entry]
Name=Pico 8
GenericName=Fantasy Console
Comment=The PICO-8 console and development environment

You will need to edit the paths if you unzip the Pico-8 to somewhere other than /opt.


cool. I have tried but found it is runing in full window mode. Any possible way to fix it? Thanks

I think that is the default behavior of Pico-8. You can change to windowed mode with Alt+Enter.

If you want to run it in windowed mode from the beginning you should execute it with the parameter “-windowed 1” (e.g. pico8_64 -windowed 1). You can see other command line parameters in in Running PICO-8 | PICO-8 Wiki | Fandom.

1 Like