clockworkpi

Pico 8 install issue

I went through the "installing PICO 8 " tutorial after purchasing pico 8 - it did not seem to work - I did all steps which worked up until the long command to add the pico 8 to the home screen (which was already there out of the box) - when I start pico 8 it say pico 8 not found add to games\pico-8 which I did but no love - any ideas

I recall having the same issue getting it to work. I can’t remember what I did, but I will try reproduce the issue and figure out what extra steps I took to get it to work.

right now i have the files under games\PICO-8 in folder called pico-8 (lower case although i have tried upper case also) when i click pico-8 from the launcher it still says copy it to ~/games/PICO-8 which I did. I tried all the other threads about it but have not found a solution yet. I wish they had the software sorted already and just asked for the key - which is another question about where do i stick that?

Dont copy the contents of the pico-8 zip file, just copy the zip to ~/games/PICO-8 and try to launch. see if that works.

i.e. ~/games/PICO-8/pico-8_0.1.11g_raspi.zip

i tried that it does not work with the zip (the current zip is 12C - is there a script that is looking for that ?

ok closer i changed the zip name to 11g in it instead of 12 c so there is a shell script somewhere that needs to be changed

when i change the zip name to have 11g instead of 12c it tries to work but then has a file checksum error and wont continue so i surmise that somewhere there is a script that is doing the install but is looking specifically for version 11g and does not work with the newer 12c

So there is a file called compkginfo.json (https://raw.githubusercontent.com/clockworkpi/launcher/e3747493ad857ba6c26763d5db29980304aa75f2/Menu/GameShell/50_PICO-8/compkginfo.json)

It has the name and the md5sum used to verify and install pico-8. change the name to your zips name and the md5 to 1a62b0d7d4e4be65f89f23ec9757cb66 (i got this value by running the md5sum command on the downloaded zip)

It installed fine with the new zip after I made these changes

ok got it working - i changed the zip name to have 11g in it then i opened pico 8 - it ran but failed the checksum sum i kept pressing A to continue but A was mapped to B so i was actually pressing B to exit. I pressed B which was actually A and it installed - phew lol

Okay, cool.

@guu There really should be a better way of installing it. It’s nice that the launcher installs and validates it but anytime there is a new version of Pico-8, people have to make sure they have the latest version of the launcher that will install and validate that version (I notice that there was just recently a commit for this too, 7 days ago to add pico-8_0.1.12_raspi.zip, unfortunately that’s already outdated as there is now pico-8_0.1.12c_raspi.zip). Maybe have it install ANY .zip file matching a pattern like pico-8*raspi.zip and just throw up the validation warning if the md5sum hasnt been added to the launcher yet. That way people have an easy installation process and can still install new versions easily without waiting for or modifying any launcher files.

Added new issue to github: https://github.com/clockworkpi/launcher/issues/182

I’ve added a PR for the latest pico-8_0.1.12c_raspi.zip, it’s now merged to master but this should not be relying on specific versions and their md5.

I bought it on Mac, how do I do these steps?