How to fix Devterm A0604 screen not turning on

i finally got the batteries for my Devterm today. When I put in the batteries the mainboard powers on. However, even though I waited 60 seconds the screen didn’t turn on. It made a whining noe. I double checked that I flashed the OS(I didn’t the first time, like an idiot) and took the devterm apart and put it back together, but the screen still won’t turn on. It still made the noise but when I plugged in my usb along with the batteries, there was the green light along with a new yellow light. I assume this indicates charging. Does anyone know if there’s anything else I can try to make it work? Thanks in advance for the help!
PS: For reference, the batteries I used were the (2300 mAh 3.7v) NL1823 from Nitecore
Here a link: Nitecore NL1823

I would try turning it on while plugged in for a bit and leave it plugged in and see if it comes on.

Have you checked the display connection?

I did check the display connection and there was nothing that looked out of the ordinary. I unfortunately have a new problem now. I tried to reflash the OS again and it won’t let me because it says it’s write protected and won’t let me format it. I think it’s because it was originally flashed using my brother’s Windows 10 laptop, whereas my laptop is running the dev channel version of Windows 11. It’s supposed to be formatted as fat32, correct?

After initially setting up my devterm I reflashed just in case and used a tool called etcher to do it. That worked pretty well.Etcher
I also had a problem with my screen not turning on initially but after having a closer look I realized that the backlight was not working. Luckily my little brother was able to help me further diagnose it and fix it by soldering new wire onto the backlight LEDs. The flat cabel that linked the backlight LEDs to the display connector was broken on one of the bends.
Hopefully that helps.


i just received my devterm this week and after assembling, adding batteries, plugging it in (i used a spare usb-c charger that came with a raspberry pi 4 i got the week before) - i experienced the same results as OP - blank screen. power light after turning it on but that’s it.

i flashed an OS from

i disassembled and reassembled the devterm. checked and doublechecked the ribbon cables.

still nothing.

what should i do next to troubleshoot this? would connecting it to a TV via HDMI be a reasonable next step?

any help would be appreciated - really looking forward to using this thing.

I assume you have the CM3, you should flash this image

well now i feel like an idiot - i assumed the compute modules were all largely the same and didn’t bother to check which i ordered (had been so long since i ordered!)

i do not have the cm3, i have the DT0604T

which OS image should i use for that? (edit: just found and will try that)

1 Like

thank you @Petrakis, my devterm is now up and running!


My devterm did not seem to turn on. Using a strong light I could see a picture, so the backlight did not turn on.
Thanks to Angr1st I checked the flat cable, the short one to the screen seemed broken.

My repair was a bit more complicated since it obviously broke closer to the screen.

I ended up dismantling the screen, soldering a bypass directly to the first LED, cutting the case to make room for the cable and reassembling. Don‘t do this if you are not good at this stuff, you can easily rip one of the cables or reassemble wrongly.

Here some photos to help those who want to try. I even had to pull the LED-strip outbof the case for soldering.

lol, new user can only post three replies per thread, and only one picture per post, so I hope those are sufficient to illustrate…

My devterm is working after this, good luck to anyone who has a problem like this!
Have fun with your devterms :sunglasses::+1:


I actually did pretty much the same (Removing LEDs and soldering new wiring on). I just uploaded that picture to show which ribbon cable was broken and because I did not take a picture of the fixed screen. The cable soldered to the ribbon cable was just for testing.

Hi I am new registered. I am an a04 owner. My cable is broken closer to the screen,too. My situation is almost similar to you, so I also dismantled the screen. I want to solder following by you photo. One thing I am not clean about your photo. Did you only solder the positive electrode of the first led? And another side on the circuit board the wire only need to solder the “K”
? Am I right?

Your break unfortunately looks different from mine. I had only ground broken, so I only soldered the black wire directly to the pad on the last LED. Your break seems to be the other line too…
It was a bit of trial and error for me and a fear dismantling my screen again to measure if the other side (the opposite last LED) can be used could brick my screen for good :scream_cat:

1 Like

OK,Thanks for your reply. I will find out where the another line should be soldered to.