I need help getting my DevTerm CM4 to boot

My DevTerm with a CM4 lite core got delivered today and I assembled it immediately. Unfortunately the device doesn’t boot. I double-checked every connection, reflashed the SD card several times and even tried other SD cards. Unfortunately the device turns on but nothing else happens. The backlight of the included display turns on for a second an that’s it. I noticed that I had the CM4 installed in the adapter incorrectly for the first time I powered the DevTerm on and fear it might be damaged. Does anyone have any idea what I can try to get my new toy up and running?

The device produces a high-pitched whine, but from what I’ve read that’s normal when you run the DevTerm without batteries.

Received my unit this week as well.

I’m in the exact same boat, except for the backlight never turns on. Green led turns on, I hear the coil-whine, but the device never boots and the display never turns on.

  • Tried multiple images (also of course the DevTerm_CM4_v0.1_64bit.img), multiple microSD cards, tried using RaspberryPi Imager as well as Etcher
  • Tried both batteries and power (5v, 2A)
  • Double and tripple-checked all connections

At this point I’m afraid I must assume the unit is defective :confused: BTW mine shipped with some non-essential parts missing as well, so overall, given how much time I waited for it, how much it costs and the fact it doesn’t work, I’m pretty disappointed.

1 Like

Could you flash with a light the screen to see if there is image but without backlight? There were issues like that where the unit boots and all but the screen backlight isnt working.

There is a thread somewhere in this forum about that and a manual fix (If you are able to do some soldering) and if its a defective backlight you can ask for a replacement screen.

And about the original post, if it was once powered on, on the wrong side, if some power pins gave current to pins that should not be powered maybe something shorted, but its difficult to say for sure.

1 Like

I received my DevTerm CM-4 this week also, and I am having the same issue. Green light turns on, but other than that nothing. I tried looking at the screen with a flashlight, no image that I could find, so I don’t think it’s the backlight issue.

Seems like a bad batch shipped at the same time, maybe? Strange that there are 3 (at least) similar issues in such a short period of time.

@Petrakis Привети :wink: I actually stumbled onto the backlight thread, shone a light - nothing seems to be rendered on the display, I also checked my backlight connections and they look like they’re soldered solid. I’m more than comfortable performing fixes and modifications, however in theory that shouldn’t be necessary on a pristine device that just rolled off the assembly line.

As @nathanbibb pointed out, it might be a faulty batch perhaps?

Today I got my batteries and tried booting my DevTerm again. Unfortunately nothing changed. The power light is green, the backlight of the display flashes and that’s it.

I also noticed that there’s an issue with the keyboard. The middle mouse button keycap is too long and keeps the other two buttons pressed down.

I’ll get in touch with support and ask them for further help and advice.

Another user reported the same issue on the Discord server. The theory that there’s something wrong with the batch gets more likely by the hour.

I just plugged my DevTerm (rec’d this week) into a monitor, and I saw a boot screen at least. It seemed to be looping through some netboot failure.


My DevTerm received at this week, also can’t boot up. Green LED in on, but screen is not on. HDMI out is the same. video signal isnt sent to external display. System fan not working.

I will contact to customer support.

@nathanbibb I also managed my DevTerm to show something on an external display. I also get the SD Card not found message.

I finally got my DevTerm to boot. I flashed the 64bit OS and surprisingly, this time the device booted. By the way, the trackball is not as bad as I imagined. It takes a bit to get used to, but aside from that it works.

1 Like

Oh wow! That’s great news. Can you post a link to the exact image you used? I tried the 64bit version but no cigar :confused:

I also flashed the SD card with the 64bit image (http://dl.clockworkpi.com/DevTerm_CM4_v0.1a_64bit.img.bz2) using Balena Etcher (balenaEtcher - Flash OS images to SD cards & USB drives), but I still get the SD card not found error.

I was told by Clockworkpi Tech to start up with batteries and USB charger plugged in, which I did - still no dice.

I have also tried reflashing the OS and trying again as support says, but it will not boot. Furthermore, I connected an external display and nothing is displayed, so it may be that the boot loader is not working in the first place. The green LED is lit.

UPDATE: I took the DevTerm apart and checked the connections, and the RPi was not seated correctly in the adapter. I am up and running now!

@yossieem, I would recommend disassembling and re-assembling. I thought for sure I had everything right, but I did not.

1 Like

My device booted successfully.

The first reason is that I attached the “Raspberry Pi CM4” to the “Adapter for RaspberryPi CM4 computing module to ClockworkPI v3.14” based only on the illustration in the “Assembly Guidelines”, which is not correct.

I noticed the mistake by referring to the datasheet of the “Raspberry Pi CM4” and checking the pin numbers.

The second cause was that the “Adapter for RaspberryPi CM4 computing module to ClockworkPI v3.14” was not inserted into the socket on the mainboard side, causing a bad connection. Insufficient insertion means that the golden part of the pin is slightly visible, and the lock works even in this state, so I did not notice it until later.

Anyway, since it booted successfully, you may close this inquiry.

Thank you very much.


Guys, you shocked me quite a bit.
My DevTerm CM4 is waiting for me at home to be assembled.
Luckily this seems to be resolved :smile:

I received mine this week too. It was working fine however i quickly ran into a BUNCH of problems. Keep in mind im still VERY new to Pi OS and i am learning as i go:

  1. updates couldn’t finish installing, specifically for the printer. it kept returning an error: Error installing packages - error while installing package: new-devterm-thermal-printer package pre-removal script subprocess returned error exit status 1

  2. A huge percentage of the software I wanted to install was incompatible with Bullseye.

  3. after HOURS this past week of troubleshooting, I gave up on trying to get anything to run on Bullseye and decided to downgrade to Buster instead. CANT.

  4. I got several SD cards and tried flashing ALL of them with EVERY version of Pi OS in the imaging software and NONE of them would boot when inserted into the devterm.

  5. Stupidly I gave up again and tried to flash the original SD card the devterm came with with a different version of Pi OS. now NOTHING I do and NONE of the different versions of Pi OS allow me to boot when I have it in the devterm.

I basically have a dead brick now or a really expensive little green LED light. Does anyone know where I can get an image to flash onto the SD card so I can have a fresh start again?

1 Like

stock image

how to create your own image

1 Like

Thank you so much. It took me all day to figure it out but I am now finally back to a fresh OS install.