Help, I am out of ideas debugging my devterm


I received my DevTerm A 06-G around June, and I never managed to make it work. It was the DIY kit, so I tried assembling it and disassembling it several times already with no luck. I checked for all the ports and connectors and nothing seems to be broken at first sight. I did also check for the screen back LEDs because I saw that was a common issue for other users, and I can´t see anything on the screen when flashing a bright light and the dev term is “on”. I also tried re-flashing the OS just in case. And I tried powering it with both external li-ion batteries and a raspi power plug.

When I try to turn it on I can see a green led, but I can´t hear any noise at all from the DevTerm starting up.

I am out of ideas for debugging, please help!

Bright green? Dim green? When “powered on”, does the orange led come on when you connect usb-c charger? Does the capslock LEDs on an external keyboard toggle when you press capslock?

Have you tried reflashing the microsd card?

First of all, thanks for the suggestions.

I already tried reflashing the SD card, yes, I downloaded the .img from here:

When I turn it on I only see one green led, which I would say is bright green, but I don´t see any orange led when I connect the USB-C charger

If I plug in an external keyboard, the keyboard doesn´t light up at all.

If I remove the plastic shell and I put my ear very close to the main board, I can hear a slight buzz sound, and after a while, it gets quite hot, so seems like something is turning on, but I would say there´s something wrong with it, can´t pinpoint what is exactly wrong.

Here you can see the light on:

If the orange led does not come on when a charger is connected, then that means the OS/kernel isn’t booting. You should try a different microsd card if you haven’t already…

BUT before you do that, here is something very important: make sure the batteries are sufficiently charged. You can connect the cable for a few hours (with the device off) to make sure it’s charged. It will still charge without the orange led coming on.

What batteries are you using?

Also, you know to [very]long-press the power button to turn it off from that limbo state, yes?

I thought the green led would be brighter, but I just checked mine… :thinking::thinking::thinking:

Hey! I will leave it charging for a while, let´s see if that helps, but I charged the batteries originally with an external charger until they appeared to be 100% charged.

The batteries I´m using are the “Sony / Murata US18650VTC5 2600mAh - 30A”. I´m totally new to these li-ion batteries, so it is totally possible that I am not using the proper ones… Please, feel free to let me know if I should use another model.

Other than that, I might have a spare SD card around home somewhere, so I can in parallel try that too :slight_smile:

Regarding the long press, yes, it takes forever to go off xD But I do the looooong press.

P.D: I’d say those green LEDs are about the same brightness, yes, hard to know because of the difference in lighting in the pictures tho :smiley:

Those Sony batteries should be good.

While looking over your photo again, I noticed your battery board contacts are not fully seated. When I install it, I like holding the battery board vertical and pushing it fully into the connector before pivoting it onto the frame.

You are right, it wasn’t totally connected, so I fixed it, just in case:

I also found another SD I had around and re-flashed the OS. (BTW, I’m not totally sure what file system I should be using).

Nothing seems to be working still :smiling_face_with_tear: The green led turns on and it gets hot, but that’s all, I don’t see anything on the screen, external keyboards don’t light up, external screens don’t display any output, the fan in the extension module doesn´t seem to be moving at all… I’m starting to think that there’s something faulty with my hardware.

Thanks so much for the suggestions so far BTW, it is so much appreciated.

P.D: I almost forgot, using the new SD card there’s a small thing that changed. Before, when I turned OFF the DevTerm, the green LED wasn’t completely turned OFF until I remove the SD card, it stayed ON as a dull green light. Now, if I turn it OFF it turns it OFF for good, no need to remove the SD card.

The filesystem doesn’t matter when you flash an image, you need to use a tool like Balena Etcher to “Burn” the image to the drive.

your computer likely won’t recognize the card afterwards, but don’t format it or anything, just take it out and try it in the device…

Good :smiley: Then I did it right. I burnt the image with Etcher

So… now that looks like is not a problem with the Software… do you know any test that I can run in my DevTerm to asses if the Mainboard or the core are faulty or not?

I’m not sure if the HDMI works before boot but you could try hooking that up, There is also a serial uart on the EXT board, if you look around the forums there are some hints on how to use that to get output from uboot/etc

Also @guu just uploaded an armbian 22 image in that thread so it might be worth trying to burn that one just in case.

I’ll give the new image a try, yes.

Also, I connected an HDMI before, just in case, and I didn´t get any output, but I can look into what you mentioned about using the EXT board.