How to setup BlueMSX for Colecovision?

Did someone managed to make BlueMSX work for Coleco emulation?
Where do you place your BIOS?
How to rename the BIOS?
Where do you place “Database, Machines” folders?


Forget it. Found the way. :slight_smile:

If someone else is wondering how to, here it is:

1 - Download the full BlueMSX from this link:
2 - Unzip the files and move the “Databases” and “Machines” folders to /home/cpi/apps/emulators/bios. If there is no “bios” folder, create one.
3 - Download from this link: and unzip it.
4 - Move to /home/cpi/apps/emulators.
5 - Create a action.config script and write this in it:

LAUNCHER=retroarch -L

*You can use Notepad++ to do this and then rename your file to action.config and move it using your preferred method. I use Filezilla.

6 - Move the action.config script to /home/cpi/launcher/Menu/GameShell/20_Retro Games/COLECO. If you do not have a COLECO folder, create one.
7 - Create a COLECO folder in /home/cpi/games/
8 - Move your games there and play!

Step 9: Point Retroarch to the right BIOS folder.
Go into Retroarch, Settings, Directory, System/BIOS and change it to your BIOS folder located in /home/cpi/apps/emulators/bios

If someone have a better way to explain all of this, you are welcome to share your method.


Hey Lix, I can’t get the roms for this to load. The screen shows the roms then I select one and the screen goes black and then back to the retro games screen. Any ideas ?

Could be the rom or your launcher script contains a typo…
Does this happen for all your roms? Are they unzipped?

Or…Did you setup Retroarch to look at the right BIOS folder?

Hey, this happens for all roms. I followed your steps to the T.

And what about the Retroarch settings?
You also need to point Retroarch to the right BIOS folder.

LAUNCHER=retroarch -L

The retroarch bios I didn’t do, let me try

Here is my latest action.config for Coleco:

LAUNCHER=retroarch -L

You can skip zip and 7z, I do not believe its supported anyway…

Thanks Lix,
The bios change fixed it!!!:slight_smile:
Many many thanks

Yay! Happy gaming m8!
I will add it to the steps.

just tried it with OS 0.4 and Launcher 1.25 (since it pre-configured in the “Retro Games” folder),
and realized, that the SO URL is wrong, and launcher can not download emulator. the Web-browser on PC also can’t…
looks like it supposed to be changed to: SO_URL=

i raised an issue on github (hope they fix it in the Launcher)

1 Like

Because it has changed since I posted the first post.


The SO_URL path is still the same. It was just a typo in your original post. Notice the “https://http://” at the beginning? If you edit your first post and remove the extra “http://”, it will work just fine. :slightly_smiling_face:

I did not made that typo in my GameShell…Just here.
For some reasons I am unable to edit the post and correct it to not mislead others…

It’s ok. Thanks for trying! I appreciate your instructions.

My Colecovision games weren’t filling the screen properly, so I hit Shift+Menu, scrolled down to Options and then set Crop Overscan = Enabled. Now they look great!

Note: that step may only be necessary if you have Retroarch > Settings > Video: Aspect Ratio = Core Provided. I prefer that setting because it helps my MAME games retain their original aspect ratios.