Several boot problems

I’ve started setting up my DevTerm and I am having significant issues getting it to boot at all.

I’ve got both an A06 module and a CM4-Lite module, and neither one seems to boot.

Using any combo of batteries, external power, and no batteries does not seem to make any difference. No orange charging LED. I am using a Google Pixel USB C charger for external power.

With the A06, I get a sharp whine, the green LED is on, the heatsink gets hot, and absolutely nothing else happens. Plugging in an external monitor displays nothing.

With the CM4-Lite (model number c03141), green light comes on, still absolutely nothing on the on-board screen, no backlight, no characters under the backlight, completely off. When I plug in an external monitor, I can see that it boots to the bootloader, but it says

SD: card not detected
Failed to open device: ‘nvme’
start4.elf: is not compatible
USB xHC init failed
start4.elf: is not compatible
This board requires new software

For the CM4-Lite I used Balena Etcher to flash onto an SD card.

I have tried another SD card for both the A06 and the CM4-Lite, and it still has the exact same results. I’m at a loss here. Is something wrong with my board’s SD card reader? I’d really prefer to get the A06 to boot, but in the absence of literally any debuggable feedback at all I switched to checking the CM4-Lite.

Any help on what I can do to get these booting?

Have you tried a different SD card? What capacity card are you using? If you have access to one, use a CM4 with EMMC to see if there is not a larger problem. Then email support to get a replacement.

Small update here. I reflashed the 32GB card that came with the CM4 board with the latest 64 bit image and that appears to have made the CM4Lite board boot successfully. Screen working, responding to inputs, everything appears to be in order there now.

As for the A06, I tried that same 32GB card, as well as a 1TB card, both same results. I used this image:

No luck. It sits there with a high pitched whine for 30+minutes, gets really hot, and never boots.

I got the orange LED once the CM4Lite booted, but the A06 does not get the orange LED ever. Just sits there whining

I wanted to add an update since nothing is worse than when people just let threads die!

I finally got it to boot by forcing the battery terminals into the slots even further than I was comfortable with, using the backside of my screwdriver. They eventually snapped into place and ONLY when the batteries were in place would it work, not via hardwired power - only batteries. If you haven’t stumbled across the many threads on this forum talking about it - it is NOT a meme, you really cannot boot the A06 for the first time only using just hardwired power. You must have batteries in place, and they must be charged. Hope this helps some future tinkerer!

1 Like