Keyboard Stopped Working after fall

My DevTerm Keyboard stopped responding after it fell off the table (the power cord hooked on my foot). My Bluetooth mouse still works

I have:

  • pulled batteries and done a full restart
  • disassembled and reassembled the unit to reseat the pogo pins.

Does the trackball work, (suspect not) Does an external USB keyboard work? Still suspect something isn’t setting quite right with those 4 pogo pins.

If the external works, bring up a terminal and try

lsusb -t

You should see all devices connected to the USB system.

Trackball does not work.

External Keyboard won’t respond (the num lock and caps lock keys also don’t light)

I have also tried a fresh image to make sure it’s not a software problem.

1,Don’t charge your devterm with PD charger, It will cause kerboard frozen.
2, You can connect a usb keyboard or SSH login, Try to update trackpoint firmware again, Then will solve this issue.( Maybe this make keyboard exit bootloader mode)
3, Or buy a ST Link cable following this thread to solve it permanently.

if you haven’t fixed it yet, try removing & reseating the CPU module.

1 Like

keyboard on my A-06 comes and goes…reboot fixes it but sometimes it boots and keyboard mouse don’t respond… external USB keyboard and mouse work fine…