clockworkpi

Keyboard and mouse stopped responding

Hi all, had my devterm for a few weeks now but haven’t had much chance to use it properly. Everything was working fine until now, when I start up there is no pointer on the screen and no response to the keyboard or trackball. I know it hasn’t frozen as the clock still runs and pressing the power key brings up the log out window, though I can’t do anything with it. I have removed and reseated the keyboard and tried an external mouse and keyboard with no luck. All I have done is apt update and apt upgrade, and installed synaptic, qemu and basilisk II. Any ideas?

I have been getting this randomly.
In my case, it seems to be related to power supply instability(plug in USB devices, detach power supply cable, etc. can trigger it).
Sometimes even rebooting couldn’t fix it and I have to power off/on.
Could this be the keyboard firmware crashing?

The keyboard module is connected with pogo pins, if the pressure is not enough maybe this could happen? I would check those and maybe press the upper part of the keyboard down a bit for testing…

A way to check if its the pogos or something else is to take it out and connect it to the USB with the micro usb, if it doesn´t work like that its the module or its firmware.

I’ve had this too, and the only fix I found was to hold in the power button and do a full forced power cycle. It wasn’t the keyboard connection in my case.

There is a protected dip switch under the keyboard. It should have an anti static amber clear sticker on it. Did you possibly switch this?
I did, on an attempt to have the Dpad appear as an arrow key to the OS. I thought I flipped switch 2; being from left to right. I should have looked harder. I flipped switch 1.
In doing so, the keybord and mouse became unresponsive. Luckily nothing was damaged in doing so, and I could return to normal by correcting the switches.

Also, have a look at this thread:

This is the dip switch in question. It seems some people have encountered physical problems with it.

I have had this problem on both my CM3 and A06 Devterm’s. On the CM3 I ended up reflashing it to get the keyboard back. The A06 I hard power cycled it twice with no luck in recovering the keyboard. After I removed and reinstalled the SD card with the unit off, it came back on power up. I have checked the soldering on both keyboard s and it is good.

P.S.
I lost the keyboard on the CM3 Devterm after I plugged in a USB Wi-Fi antenna. The A06 keyboard stopped working after a reboot after installing flatpak.

This has also happened to me once, external mouse didn’t work as well. Pressing the power button did bring up the UI, I just couldn’t move the mouse or use any keyboard input to navigate. I didn’t have time to diagnose fully, multiple hard restarts didn’t fix it. I ended up re-flashing the SD card and that did fixed it, everything is still working a day later.

I was working on installing updates and new software when it locked up the first time (after a reboot.)

I’ve also had this randomly happen - and like some folks here, most times I can recover with a reboot but one time I had to flash the card.

Yesterday, this appears triggered by me experimenting with new battery cells so this seems inline with the theory that changes to the electrical load can trigger this issue.

Thanks for all the advice everyone. I removed the keyboard and plugged it into my laptop, keyboard worked fine but the moving the trackball made the pointer disappear. Then plugged the keyboard into devterm USB, started up and managed to log out by accident, logged back in and everything was working again. Reseated the keyboard back in place and all is fine again.

1 Like

Thanks for the update, this might help others with this problem.

I love this forum, the users are really helpful! nothing like those windows forums where they just post „thanks for the help“ and omit the solution…

1 Like

Yes that happens in windows and linux PC, probably the coordinates of the screen of the DevTerm don´t translate well to the monitor of the pcs and makes a big jump.

This problem happened to me today… booted my Devterm this morning and no serial worked. @packmule43’s advice above to remove and reinstall the SD card got me working again. How strange!

Now this is interesting. Does anyone get strange key assignments as the temperature increases?
At first I thought it was my fingers leaning on a key, giving unexpected output, since there’s no physical tactile feel to key pushes.

Then while browsing I decided to push the ABXY keys (which have been dip switch 2 modified to be keyboard keys) and for some reason it started going back and forward in my browsing history.

The first thing I thought was, cool! Browser navigation with ABXY! Then it suddenly turned off. It was almost as if one of the keys triggered a shutdown. The batteries were at 50%, and I was running all 6 cores, for thermal testing.
Upon restarting, they no longer functioned this way.

The only thing I can put it down to is heat. Perhaps this is what causes the keyboard and mouse to stop working. In which case, perhaps some kind of insulation to prevent as much heat transfer could be applied. Or rather, have the heat pulled away from the CPU more effectively.

No problem, I can find my way around Lunux but far from an expert and in awe of those who are. Still don’t know what actually fixed the problem. Forgot to say I also removed the batteries just in case. So it could have been this, or logging in and out, or reseating the keyboard (twice), who knows? Hopefully it won’t happen again!

I made a separate thread (After first use keyboard & mouse no longer works, how to recover?) because I didn’t notice that this one exists. Sorry.
What I noticed is that sometimes a quick power supply demand rise (connecting something to usb, which consumes power) can make the keyboard stop.
In such cases turning off and on helps for me currently.
This looks like the kezboard firmware crashing indeed
(also as I reprogrammed the keyboard with the ‘improved trackball firmware’ I think I’m getting this much less often but not sure if this is related at all)
Wouldn’t some kind of watchdog (& restart) in the keyboard firmware solve this?