Lets play Snake

retroarch

#1

If you followed the instructions to install the FloppyBird game you can skip the steps until making the gamefolder for snake.

Open Retroarch on your gameshell
Select Load Cores
Select Download Core
Select Chailove
Quit Retroarch

Connect your device to your gameshell with SSH

Lets move the core to the emulators folder.
(If you use another folder to save your downloaded cores navigate there)

mv ~/.config/retroarch/cores/chailove_libretro.so /home/cpi/apps/emulators

Make a folder for the game (start here if you allready have FloppyBird installed)

mkdir ~/games/Snake

Navigate to the games folder

cd ~/games/Snake

Download the Snake.chai file

wget http://buildbot.libretro.com/assets/cores/ChaiLove/Snake.chai

Make the .sh file

nano ~/apps/launcher/Menu/GameShell/Snake.sh
(change Snake if you want another name in the menu)

Add:

retroarch -L /home/cpi/apps/emulators/chailove_libretro.so /home/cpi/games/Snake/Snake.chai

Save and quit

Move the icon to ~/apps/launcher/skin/default/Menu/GameShell

cd ~/apps/launcher/skin/default/Menu/GameShell
wget https://raw.githubusercontent.com/ocr-junky/GS_Icons/Icons/Snake.png

Make sure the icon has the same name as the .sh file. In this case Snake.png

Reboot and have fun :smiley:
Watch out pressing the opposite direction of the way you are moving, it will kill the snake instant.


#2

Just a little screeshot
Snake-180904-210148


#3

Thanks! I think you forgot chmod +x ~/apps/launcher/Menu/GameShell/Snake.sh :slight_smile:

P.S. Although, you might not need it as it runs with /bin/sh /home/cpi/apps/launcher/Menu/GameShell/Snake.sh.


#4

For me it worked flawless without chmod the sh file. If You have trouble booting snake doing the chmod to the sh file seems a good idea.


#5

Nah, it probably doesn’t need it.


#6

From the picture it looks I played this game before:thinking: well quite interesting when you get your old version game. From this, at the childhood, I also like to play Super Mario game on the big system I remembered. Has somebody tried this game ever?