clockworkpi

Let's Play... some Debian packaged games from the Warehouse

What is this?
All of the “apt” games in this warehouse could be installed manually on the command line using apt-get (or apt). But I decided to set up a warehouse to make installation easier (only the Gameshell, with a working internet connection is required), and I included commands in the scripts to map the controls to the Gameshell buttons.

How to get them?

  • Go to the Warehouse.
    capture
  • Add the new one by using Add new warehouse… and editing it to match the highlighted name here. github.com/madcock/warehouse
    capture-2
  • Once it shows up in the list, select it and you should see apt Games.
    capture-3
  • Selecting that will show the list of games which can each be installed and then played.
    capture-4

What are these games like?
For more information about each game, check the warehouse on github. I put links in the README.md of each game there.

Controls
At some point I need to document the controls, but for almost every game, quit is via Menu, and A and B are the main buttons in game. Spout is unique – quitting must be done with BOTH the Menu and Select buttons pressed together.

What’s all that stuff on screen when I first get the game?
These are slightly different from the existing Game Jam warehouse entries because the first time you run each one, it will use apt-get to download the actual game files. Only the first time you run it, a terminal window will appear, showing what is going on. Once installed, the game will run. Next time you use the menu to launch the game it will just run since it will already be installed.

What’s next?
I plan to add more games to this warehouse, and all of them (in the apt section) will be freely available games in the Debian distribution, with customized configuration (controls, display size, etc.) for Gameshell. A few I might include have already been described here in the forums (like Wolfenstein 3D), and others (like Ur-Quan Masters and Kobo Deluxe) haven’t been described yet. Some require some configuration file editing after installation, so the display fits the Gameshell, and I’ll try to automate those edits in the installer scripts as well. The Warehouse should make them easier to install without requiring SSH or another machine besides the Gameshell itself.

6 Likes

This is such a great contribution! Thank you so much.
You mentioned… Ur-Quan Masters? YOU HAVE MY ATTENTION! :smiley:

On another note, did you remove any of the warehouse games from your initial batch I tested before?
I was just thinking. That could be a potential “bug” in the warehouse system, ie the inability for a basic user to a) access previously installed games and b) uninstall games, if the host removes them from the warehouse list.

No, I didn’t remove any games. The “box86 Games” entry is still there, pointing to the ones I mentioned before. I’m not sure this is the best way to organize them, but I figured keeping all those games in one place (since they rely on the box86 emulator, and it’s still being developed and improved by ptitSeb) and the apt-based games in another made sense. I might update the contents of the box86 games at some point, to include a newer version of the emulator if it gets noticeably faster, but I don’t plan to update it regularly. The apt stuff shouldn’t need to be changed at all since those repositories shouldn’t be changing names, and the script is just installing what is available at the time it’s run.

You’re right though, as far as I know if I did remove anything from the git location, it would disappear and be unavailable in the warehouse for anyone. I wouldn’t do that unless there was a reason (copyright violation, game was horribly broken and I somehow posted it anyway, etc.), and even if I did I’d post about it on the forum somewhere. But it’s something that could happen with warehouse git repositories.

As for uninstall, there’s no way to do that now in the case of the apt games I just posted. All I put in those warehouse entries are scripts to run apt-get and install the game and then later run the game once its installed. But if someone deletes the warehouse entry from their device, it doesn’t remove anything that was installed via apt-get. And I don’t know of a way to hook into or “know” when a warehouse entry is deleted so all the potentially installed stuff could be removed with apt-get. I could create scripts for that and either put them in the same apt warehouse or a new “remove apt Games” entry, but it would still be up to folks to remove them before removing the warehouse.

I’m not even sure it removed the files for the game jam warehouses, which include everything “pre-installed” as part of the warehouse. I’m pretty sure I’ve seen files leftover in the /home/cpi/aria2download directory even when I removed a warehouse. I’m not sure if that’s a bug, or the intended way it should work.

There is also no indication (or way to show) how much space anything might take up when installed. So anyone running low on space on their SD card should probably never install anything from a warehouse because I’m not sure what would happen if it tried to install something and they ran out of space.

Currently the warehouse offers pretty barebones functionality, and very little to help people create, or more importantly check/debug any warehouse they might want to create. But I think it’s useful, and saw it as a way to make some of the stuff available to Debian distros like Gameshell more easily accessible to folks who may not know it’s already there or how to get to it. :wink:

As for Ur-Quan Masters, I could have added it to this batch, as I’ve had it running for quite some time (well before the warehouse became an option). It’s just as easy to install through apt-get (though it’s rather large, weighing in at several hundred MBs I think?), but it comes in several packages since the music and voices and stuff are separate. The tricky thing on Gameshell is that once it’s installed, it will run, but the default screen size is too large for the display. When I set it up a while back, I had a monitor hooked up via HDMI cable, and changed the settings to 320x240 and also remapped all the keys to the Gameshell buttons. While that worked for me, it’s not what I need to set it up and have it preconfigured after a warehouse install. I found the settings are stored in two files in /home/cpi/.uqm. So I need to nuke it (and the config files) on my device, reinstall, and then get a copy of the default settings files to compare to what I have now. I don’t remember what changes I made, and I’d rather keep it as minimal and clean as possible. I figure I can just install the modified configs in the warehouse, and then copy those files over the newly installed game (but ONLY after the install, to allow for folks to make their own config settings later). As an added bonus, if someone wrecked their config, they could just go grab the copy from the warehouse location in /home/cpi/aria2download/madcock/warehouse/master/Games%20apt/[whatever I call Ur-Quan Masters]

:slight_smile:

But yeah, that will be coming later this week.

2 Likes

I’m also wondering about a few other games that require grabbing source from github, compiling, and installing. It’s probably safest to just include pre-built binaries in a “Ported Games” warehouse entry. But I should also be able to script the compilation process similar to the apt-get stuff in this batch. Then the warehouse would be used to grab the sources, build them, install them, and then once the binary was available the same script could run it and also reconfigure the buttons (if needed) like I’m doing here. Part of me thinks it would be a learning opportunity, or at least be interesting to folks if they saw stuff being built that way from the warehouse, but I also worry that it could be more of a mess if someone is low on power and the Gameshell turns off during a build, or they lose internet connection while downloading sources, or some other unexpected thing happens and leaves things in a weird state. On a positive note though, they could actually go in and look a the source code and potentially change it later and rebuild if they wanted to. From a documentation and history preservation aspect, and maybe even a device compatibility aspect, I think it makes sense to build the code this way on each device, but if folks just want to quickly get a thing and play it then it makes more sense to put the pre-built binary in a warehouse and hope it works on their device. ¯_(ツ)_/¯

I’m open to suggestions on that!

2 Likes

The learning aspect is very much a part of what I think the gameshell should be used for, but as we’ve seen there are some who get frustrated with the notion of troubleshooting.
If you even wanted to have a separate repository just for testing purposes, that is a sure shot way to get the community to give feed back on the fly.

You raise some very good points re: what would happen during a) low power failure, b) low disk space and and c) lack of debug features. I hope the next version of it comes with these issues addressed. The easier it is for people to upload the content, the more content the warehouse will get. I thank you again for doing this, despite the hurdles! Your work is definitely noticed!

On a side note, I actually tried to look for a ur-quan port a while ago. Was it on here, or something you ported by yourself? I may have just spelled it wrong haha.

1 Like

I just added Ur Quan Masters. :slight_smile:

capture

It turns out there is a command line option to set the screen resolution, so all I really needed to do in the script was adjust the Gameshell key bindings to the defaults for uqm, and one other thing so it found the packages. Keys can be redefined in the game options if you don’t like my defaults.

Note that while it’s installed via a regular deb package, it’s in a different location than usual, so the script does a bit of hackery on the sources.list to add the “non-free” stuff. The game however, is free, as described here.

The default installation seems to use the most compatible options (aside from the screen size which I fixed). It supports some filters and GL, but by default it displays the original game graphics as they were on the PC back in the day. Funny enough, the default resolution then was 320x240, so it fits the Gameshell perfectly! I haven’t actually tried all the in-game option settings, so I don’t know if all the filters and things work. But the game runs fine.

For the curious, like @javelinface, here’s the launch script I ended up with. You don’t need to do anything with this since the warehouse takes care of it all, but just FYI:

#!/bin/bash
APPNAME="uqm"
PARAMS="--res=320x240 --fullscreen"
PKGNAME="uqm uqm-content uqm-music uqm-voice"
 
# Install if necessary.
type $APPNAME >/dev/null 2>&1 || {
 	x-terminal-emulator -e "printf '$PKGNAME not installed. Installing...\n' && sudo sed -i -- '/^deb .*stable main contrib$/ s/$/ non-free/' /etc/apt/sources.list && sudo apt-get -y update && sudo apt-get -y install $PKGNAME"
 }
 
# Remap keys
xmodmap -e "keysym j = Control_R"
xmodmap -e "keysym k = Shift_R"
xmodmap -e "keysym u = Escape"
xmodmap -e "keysym i = F1"
#xmodmap -e "keysym Return = Return"
#xmodmap -e "keysym space = space"
#xmodmap -e "keysym KP_Subtract = KP_Subtract"
#xmodmap -e "keysym KP_Add = KP_Add"
xmodmap -e "keysym Backspace = F10"
xmodmap -e "keysym h = Next"
xmodmap -e "keysym l = End"
xmodmap -e "keysym y = Home"
xmodmap -e "keysym o = Prior"
 
# Run application
$APPNAME $PARAMS
 
# Restore xmodmap keymappings.
# NOTE: Reboot or run this command manually if keymappings fail to restore due to crash, etc.
setxkbmap
2 Likes

This is a great use of the Warehouse functionality :sunglasses:

I wonder if you could use feh or some other image displaying command to show the controls at launch briefly (or while a button is held during launch)? Then you could simply include a 320x240 png with each game.

2 Likes

Thank you so much for indulging my curiosity!! You know I love this stuff. >:)
I am about to install it, but just as a side, assume that the keyboard/arduino needs to have the mouse cursor flashed to it, given the nature of the input in the game.
Colour me (pleasantly) surprised if it doesn’t!
(Not gonna get time to play/fiddle, since it’s almost 3am - even though I really want to!)
And I caved. In bed at 4am. Tried UrQuan. Initial execution went to download audio files. Seems the sources.list is still using the Chinese tuna mirror, uses in 0.5. Unfortunately it didn’t run, even after executing if multiple times.
You mentioned the script altered the sources?
Could you possibly post up the modified repositories? I’ll see what happens if I chance them manually.
I tried a few other games, and they worked.

It doesn’t require the Arduino update – Ur-Quan Masters doesn’t use the mouse at all. It only uses keyboard controls (or gamepad, which I guess could work if you connected an external one but I haven’t tested that.)

None of the games I’ve posted require a mouse, and I was intentionally avoiding those since I wanted everything to just work with the official OS that folks are likely to have installed.

Yeah, it needs to download all the packages. Make sure you have a good internet connection. If it failed, it shouldn’t be much of a problem – running again will cause it to try to install the packages it didn’t get the first time. Although it will only install the content, music, and voice files if the application itself is missing (since my script only installs stuff if the core game is missing). So if you somehow successfully installed the game, but it failed to install the content, the script probably won’t try to install it again since it will find the game and assume it’s installed. The other games were just a single package, where Ur-Quan Masters has 4. Only the uqm and uqm-content are required, but the game is so much better with the music and voice packages too. It’s also over 200mb or so when all installed, so make sure you have the space for it.

Yeah, it’s annoying the official repositories are in China so connections to them may be dodgy. I haven’t had too many issues connecting with them, but it fails for me too sometimes. For the next update I hope they consider a few regional releases since it’s not good for everyone if we have to connect through only CN or the US. I’d be fine with the US since that’s where I am, but it might make sense to have a EU one and maybe others too. I thought about changing my sources list to use a US location but I just hadn’t bothered with it yet.

The changes made to the sources list are in the script I posted above:

sudo sed -i – ‘/^deb .*stable main contrib$/ s/$/ non-free/’ /etc/apt/sources.list

It just adds “non-free” to the end of the stable main contrib line.

If you did lose connection in the middle of running the script and it only installed some of the packages but not all of them, you can just manually do a:

sudo apt-get install uqm uqm-content uqm-music uqm-voice

and that should get everything set up. The next time you run the script it will just run the game if everything has been installed.

By the way, you don’t just have to run stuff from the warehouse after it’s installed. You can copy the game directory with the launch script out of that “aria…” directory (I forget the name since I’m not looking at my device at the moment) and move it to somewhere under apps/Menu if you want. That way you can organize it how you want and not be stuck having to only run it through the warehouse. I’ve included icons for the launcher with most of these games (Ur-Quan Masters has one), and you’ll see those if you move it to the menu after installing. Consider that an easter egg. :wink:

1 Like

Running the

sudo apt-get install uqm uqm-content uqm-music uqm-voice

command separately did the trick. Doing it directly from the warehouse menu would stop prematurely each time, just downloading the first file. I’m guessing this is the core game file package, given it kept on attempting to download all the packages. I’ll get a screen shot of it.
Quite a curious problem, that clearly isn’t anything wrong with your code.
Haha also, nice Easter egg. And very cheeky! You never fail to surprise. Much appreciated :wink:

Hmm, I’d like to try to fix this. I uninstalled with apt-get remove and tried doing it all via the warehouse (before I first posted the link) and it worked for me.

Have you had issues with apt-get failing from the command line too? If it’s just the default CN repo being unreliable I can’t really fix that. It’s probably slower than it needs to be but I don’t think I’ve had it fail for me yet.

One thing I could do just to be a bit safer is break that single install line out into separate parts and check if each package is installed. Just checking for the executable worked fine for simpler games, but since this is in parts and a part could be missing if it failed to download, it might get it a weird state. While it could be fixed manually, I was hoping I could get it to be more bulletproof from the warehouse itself. I’ll see what I can do to improve it.

2 Likes

Definitely am wanting to help with that! I’m loving your work, and want to make sure everyone can experience it properly.
For the record it was done on a clean installation to try and get rid of any possibly erroneous factors. I’ll post a video of it in a few moments.

For now, here are the logs from the successful run, so you can see what was installed on the side.


And here’s a video of the error, seemingly replicated using the warehouse. I flashes a new image, and the same result. For the record, every other game works in your warehouse.

https://share.icloud.com/photos/0CemtkWYg95HLDZltClWSzxCQ

I am admittedly using my modified OS, but it’s basically identical to a stock 0.5 configuration. I’ll try with a stock 0.5 next.

I’m pretty sure your successful install log (which you got by manually entering the command) is what I saw scroll by when I used the warehouse on my end. There was definitely a lot of output, and references to each package as it installed them. I’m assuming after doing that it worked via the warehouse too, since it could find the main program to run (just checking)?

Your video is helpful (but strange!) It seems like it was failing at different points each time you tried. I downloaded your video and loaded it up in avidemux on my desktop, so I could step through frame by frame in the hopes of seeing what was on the screen right before it quit/crashed and went back to the DEOT launcher.

First try:
image
The message at the bottom that is faded is the best I could get. All I can read (kind of guessing to) is the the last few lines:
??? [URL for the repository?]
??? is required
??? Updating for this rep
ository will not be applied.

So it seems like it is maybe some kind of dependency issue or conflict with something already installed, or maybe you need something that isn’t installed automatically? The truly bizarre thing is that it worked when you ran it manually. And it’s the same command!

Ok, try # 2 in the video:
image
Looks like the same message, and the first line is brighter, but it’s blurry and I can’t read much more than before. But I’ll add to the other one:
??? [URL for the repository?]
??? is required
??invalid since 14h 29min 21s), Updating for this rep
ository will not be applied.

Try #3 (last one):
image
At least those last lines are brighter this time, and I can make out a bit more:
?? Release file ??? http://mirrors.tuna.tsinghua.edu
.cn/debian/distro/stable-???/??? is required
(invalid since 14h 29min 21s), Updating for this rep
ository will not be applied.

Although I’ve used apt-get in the past, I’m not really sure what’s going on here and why it works when you run the command but it doesn’t work when the script ran the command. Is it possible the repository itself changed or files weren’t available when you used the warehouse, but then it was back online when you ran the command via SSH? If anyone else has ideas, I’m curious what was going on here.

In other news, I did a bit of poking around to see what kind of commands are available to discover if a package is installed. I’m thinking I should use dpkg-query like this.

dpkg-query -W -f=’{Status} {Version}\n’ uqm uqm-content uqm-music uqm-voice

which produces (for me):

install ok installed 0.6.2.dfsg-9.5
install ok installed 0.6.0+deb1-6
install ok installed 0.6.0+deb1-6
install ok installed 0.6.0+deb1-6

In the script I’m thinking I could just run it for each package, check for the “install ok” at the start of the line, and if it’s not found then install that package. If I broke out the four Ur-Quan Masters packages like that, then hopefully it would better ensure all four were installed before it tries to run the game. And if this works, I should probably go back and do this for all the other “apt Games” in my warehouse since it would be better doing what I was trying to do in the first place, rather than just checking to see if the game executable was installed.

Also, I’m thinking I should see about finding a way to dump output shown on the screen to a log file too. I need to brush up on redirecting output. That could come in handy for debugging. In this case it would have saved you having to make the video, and me trying to play detective with frame by frame screenshots on it. We could have just looked in the log file that contained everything that was shown quickly on the screen! :wink:

I still don’t know what’s going on with your warehouse attempts on UQM though. But it does start properly after you’ve installed it manually, right? And the Gameshell buttons work in game, etc.?

One other thought – could you show the contents of your /etc/apt/sources.list ?

Mine looks like:

# deb http://mirrors.tuna.tsinghua.edu.cn/debian/ stable main

deb http://mirrors.tuna.tsinghua.edu.cn/debian/ stable main contrib non-free
deb-src http://mirrors.tuna.tsinghua.edu.cn/debian/ stable main

deb http://mirrors.tuna.tsinghua.edu.cn/debian-security stable/updates main
deb-src http://mirrors.tuna.tsinghua.edu.cn/debian-security stable/updates main

# stable-updates, previously known as ‘volatile’
deb http://mirrors.tuna.tsinghua.edu.cn/debian/ stable-updates main
deb-src http://mirrors.tuna.tsinghua.edu.cn/debian/ stable-updates main

The only thing the script should be changing is adding “non-free” to the end of that line up top.

Yup, the sources.list was updated successfully.

# deb http://mirrors.tuna.tsinghua.edu.cn/debian/ stable main

deb http://mirrors.tuna.tsinghua.edu.cn/debian/ stable main contrib non-free
deb-src http://mirrors.tuna.tsinghua.edu.cn/debian/ stable main

deb http://mirrors.tuna.tsinghua.edu.cn/debian-security stable/updates main
deb-src http://mirrors.tuna.tsinghua.edu.cn/debian-security stable/updates main

# stable-updates, previously known as 'volatile'
deb http://mirrors.tuna.tsinghua.edu.cn/debian/ stable-updates main
deb-src http://mirrors.tuna.tsinghua.edu.cn/debian/ stable-updates main

If you want, I can see if I can take another video, as it is completely replicable. I take it you meant the output was strange, and not the voices in the background! Haha. I would just do it via a remote terminal, but ha! It’s that way that makes it work.

I was just SSH ing via my mobile phone, in bed because I was lazy. So there’s no way that there was anything connected via a different connection. I then did it with the command separately, and it was successful. If the timing of the server just happenned to coincide with my attempts twice, ha. Well. I guess I am just cursed. But realistically I doubt it very much.

Could it possibly be to do with using sudo commands, and/or writing to a non user, root directory? Particularly with regards to using warehouse.

I’ve started using apt instead of apt-get, just due to being newer, and for being more “future” orientated. I haven’t had too much back compatibility problems. Would this be somewhat related?

Just throwing out possible thoughts. Because Ur Quan Masters is a classic everyone really needs to experience, and I am glad that we can!

why still use china mirror ?
using netselect-apt could generate new sources.list according to your real location
https://linuxconfig.org/how-to-find-a-fastest-debian-linux-mirror-for-your-etc-apt-sources-list

1 Like

After a bit more research I’m wondering if the problem is my use of sudo to add the “non-free” to sources.list inside the script. It sounds like, for obvious security reasons, sudo is tricky to use inside of scripts. For example, there’s more information here:

It must not be too restrictive though, because it sounds like the apt-get install commands were working for other games.

@javelinface, did using the warehouse actually update your sources.list, or did you do that manually too? If the warehouse script actually worked, but only the install commands failed, then I’m really confused.

There is another way, but it feels dirty. Instead of adding “non-free” to the sources.list, I could use wget to download each deb file directly, install them, and then delete the deb file. So something like this:

wget http://http.us.debian.org/debian/pool/non-free/u/uqm-content/uqm-content_0.6.0+deb1-6_all.deb
dpkg -i uqm-content_0.6.0+deb1-6_all.deb
rm uqm-content_0.6.0+deb1-6_all.deb
wget http://http.us.debian.org/debian/pool/non-free/u/uqm-content/uqm-music_0.6.0+deb1-6_all.deb
dpkg -i uqm-music_0.6.0+deb1-6_all.deb
rm uqm-music_0.6.0+deb1-6_all.deb
wget http://http.us.debian.org/debian/pool/non-free/u/uqm-content/uqm-voice_0.6.0+deb1-6_all.deb
dpkg -i uqm-voice_0.6.0+deb1-6_all.deb
rm uqm-voice_0.6.0+deb1-6_all.deb
#sudo apt-get install -f  #optional, maybe needed but I'd need to test

That’s a lot of extra junk though, and it would also prevent apt from updating the uqm content if anything changed in future. (It seems unlikely to change though!)

As a side note, a similar technique using wget could be added to grab the 4 optional music remix packs, as mentioned here:
http://sc2.sourceforge.net/downloads.php

They’re quite good and improve on the original music content (which was already amazing), but I’m not sure I’d want to force them to be installed. They take up quite a bit more storage space. It’s possible to select them from the options menu if they are installed, so it’s easy to switch back and forth, but I’d expect they’d be hidden and go undiscovered by most users. And the default should be the original content anyway, I think.

@r043v, your netselect-apt suggestion is really useful! Thanks for that. I ran it, got the fastest mirror for me, and then updated my sources.list. It’s a LOT faster than before. So it seems like the user experience for anyone getting a Gameshell and using the official build will be kind of poor (at least for software update speeds) unless they live in China. :frowning: Like I mentioned before, maybe it would make sense to release a couple of builds “tuned” to different locations (maybe just inside and outside of China).

So what do you think? Should I try the hacky method of grabbing the deb files directly? (That raises the problem of where the files come from again, so if I used a US based location, they might be intolerably slow for Chinese users.) I’m still not sure what was causing the original problem. @r043v have you tried installing Ur-Quan Masters from the warehouse? Does it fail the same way for you?

I’m also wondering if my system was in a different state, in terms of packages and updates. Though I’d been running apt-get update before installing stuff (and I’ve been installing a lot), I hadn’t yet done a apt-get upgrade. I just ran that today, so I got a bunch of updates to, well, practically everything. I’m hoping nothing new breaks as a result!

1 Like

be sure your sed will work fine, as you && after it it may not continue if it not match ?
( https://stackoverflow.com/questions/15965073/return-code-of-sed-for-no-match
edit > miss read the answers, it always return success

still use directly apt as you do, if there any update, manually change all packages uri to maintain is not really possible

i think you may create an warehouse entry dedicated to change sources.list mirrors and include the non-free repo

as i don’t run clockwork os i cannot test your warehouse entry, i may create a compatible client in future but it anyway will not like apt stuff

for the sudo thing i personally run things as real root :

sudo su - -c "commands to run as root"

1 Like

This should be something standardised, re automatically changing sources.list according to location.

@adcockm I didn’t need to run the sources.lists script modification separately, making it seem as though at least that part worked.
It would seemingly fail after the wget part of the process.
It may possibly be the unpacking process, since it looks like it’s downloading things all properly.

This just gets curiouser and curiouser. I wish I could figure out a way to easily replicate thr problem on my end. I’m not really excited about flashing a card (assuming I have a spare, which I think I might) just to try to see this happening. As you suggested, we could try using apt in the script instead of apt-get and see if that helps.

I had one other thought that would be less messy than the separate wget commands, but that I don’t like much either… I could include the installed content in the warehouse entry and then just move it to the proper location (or create symbolic links to the files that would be in the warehouse area). That way nothing would need to be installed at all, and it would be like most other warehouse entries. I don’t like this for several reasons though… For one, I didn’t create this port or uqm and I don’t like the idea of tearing apart an installation package that was set up ages ago and has worked all this time on other platforms. It would also be a large warehouse item to install, and perhaps even too large to store on github anyway. I’m pretty sure there is a per file limit of 50-100mb and this setup would probably require that single tar.gz file to be 200mb or more. Even if it did fit into the space requirement it wouldn’t be ideal.

What would be really helpful is if someone else tried to install the current warehouse entry for uqm. At this point I don’t know if it’s an issue with your custom DEOT 5.0 image, something that happens with both it and the official 5.0 (which I somehow avoided because my system had a change I missed or was unaware of?), or if it can be successfully installed by others on DEOT and official 5.0 and this was just a weird thing with your setup, @javelinface. And I guess it still could be a hiccup with the default Chinese repository. I’d rather not spend a lot of effort trying to come up with another more awkward way to install the files, when I’m not even sure why this method didn’t work, and we don’t even know it if affects anyone else. :frowning:

Honestly, I’d rather get more games working and send more results to ptitSeb to help improve box86 so more stuff runs that way too.

But I do want to figure this out. I just feel like I run the risk of tryng to fix something that may not even be a widespread problem.

1 Like

I’m going to flash a card with the stock 0.5, and test it out! Just posting this here, so you don’t have to worry about doing it. Will edit this post with findings ASAP!

Another thought. And this is messy. Have a separate entry to install the UQM dependencies, and yet another one if people want the additional/alternative music pack?

1 Like