clockworkpi

Issue fetching from warehouse repos

Hello, New here! Been a silent lurker for a while now keeping tabs with the new A04 devterm shipments and I’ve snagged myself a used Gameshell during the wait to tide me over.

I’ve cleaned it up and flashed a fresh v0.5 image to it and I’m loving it so far but I’m having an issue getting any indie titles from any of the default warehouse repos.

When selecting any title the screen hangs and stays frozen indefinitely with no response leaving me with resorting to a hard shutdown after a decent amount of time.
on rare occasions I get an actual message box for a split second saying something about downloading but it quickly disappears and goes back to what it normally does.
I can still fetch screenshot previews just fine on all titles without a problem.

I’d love the convenience of using the built-in repo system instead of doing things the long way.

any troubleshooting advice?

After a digging I found out that the aria2c(indie game downloader daemon) of the current launcher got Aborted every time when trying to download the game package from GitHub

it’s weird, aria2c reported TLS handshake fail

and because aria2c exited, python code got crashed, launcher crashed

now you can try to update the launcher, I’ve just replaced a new aria2c to launcher now

here are the testing steps I’ve run into if you are interested:

first ssh into GameShell

maybe use the gnu screen to have a multi-tab console

  1. kill all launcher ,appinstaller.py and aria2c process

  2. run aria2c with aria2c --conf-path=/home/cpi/launcher/aria2.conf , I changed daemon=false in aria2.conf

  3. run appinstaller.py

  4. DISPLAY=:0 ./load.sh to run launcher

then you can see the console log output ,python crash logs ,etc…

A small workaround is to get the games “offline” from the repos and install them manually

For example in the json you can find the compressed files.

And for the aria2c there are couple of issues about that on the repos I tought the TLS fail would have come from the letsencrypt DST root expiration but seems its not DST Root CA X3 Expiration (September 2021) - Let's Encrypt

1 Like

Thank you for your patience in advance, I’m a novice

So I’ve ssh into the gameshell and tried using htop to kill the necessary process trees but they all just reload after I try, I’m not sure what to do about that

edit: Whoops just read Petrakis’ post.

just kill launcher, not the whole X

ps aux | grep load.sh 
ps aux  | grep run.py

And I recommend go to launcher ,Settings-> Update Launcher

I try to kill the processes that ps lists but some of them refuse to go, also is it normal for the PID of a process to keep changing?

Edit: The launcher just refuses to go but I can change aria2c’s conf path with aria2c --conf-path=/home/cpi/launcher/aria2.conf and I’ve gone in with nano and changed daemon=false

also where is appinstaller.py located?

appinstaller.py is in ~/launcher/sys.py/

did you try to update the launcher?

The launcher says it’s up to date

Here’s what i’m getting:

__
cpi@clockworkpi:~$ ps aux | grep run.py
cpi 1106 1.2 16.8 149068 85848 tty1 Sl 19:07 0:18 python run.py
cpi 3657 0.0 0.1 6732 556 pts/0 S+ 19:32 0:00 grep run.py
cpi@clockworkpi:~$ kill 1106
cpi@clockworkpi:~$ ps aux | grep run.py
cpi 1106 1.2 16.8 149068 85848 tty1 Sl 19:07 0:18 python run.py
cpi 3663 0.0 0.1 6732 540 pts/0 S+ 19:32 0:00 grep run.py

I’ve also tried killing these in htop

Specifically PID 1106 just doesn’t die and any instances running under “pts/0” keep changing so I can’t catch them. I can kill “load.sh” but just the one running in tty1

I’ve tested the launcher
update is avaiable

and for the kill 1106 , try kill -9 1106
kill -9 means force to kill it

if kill -9 is not hard enough, do it with sudo
sudo kill -9 1106

ALSO
for a quick test

cd ~/launcher
rm -rf aria2c
wget https://github.com/clockworkpi/launcher/raw/master/aria2c
sudo reboot

the problem is just the aria2c ,so replace the aria2c will slove

I’m up-to-date

Kill -9 works, I’ve replaced aria2c and rebooted however, now It looks like there’s a syntax error inside of appinstaller.py when I try to run it

__
cpi@clockworkpi:~/launcher/sys.py$ python3 appinstaller.py
File “appinstaller.py”, line 114
print “on open”
^
SyntaxError: Missing parentheses in call to ‘print’. Did you mean print(“on open”)?

I went in to fix and put parentheses there but now I get:

__
cpi@clockworkpi:~/launcher/sys.py$ python3 appinstaller.py
Traceback (most recent call last):
File “appinstaller.py”, line 6, in
from wicd import misc
ModuleNotFoundError: No module named ‘wicd’

Not sure how to get that “module”, I think I’m missing some things
I have a lot of learning to do :sweat_smile:

Also the launcher is super dead and I’m not sure where to find load.sh to start it back up

launcher all code is in python2

I get


[Errno 97] Address family not supported by protocol

when I try to run appinstaller.py in python2

ssh into GS

rm -rf ~/launcher
git clone  --recursive   https://github.com/clockworkpi/launcher.git
sudo reboot

connect to wifi then try again

It looks like that worked, thanks so much for spending time to help!
Time to get inspired and check out some cool stuff people have made! :grinning_face_with_smiling_eyes: