clockworkpi

GameShell OS image files (v0.5)

Hi GameShellers,

We are more than happy to announce that the Clockwork OS v0.5 is ready to go!
We are sincerely grateful for the support from the community. The creativity and concentration inspired us a lot. YOU GUYS ROCK!

WeChat Image_20200104162852
Download:
http://dl.clockworkpi.com/clockworkos_v0.5.img.bz2 ==> Mirror #1 ==> Torrent
md5sum: 27f85542d0278f898bfca060c264dc6f
(Updated. Fixed a few bugs found in this thread)

v0.5 latest release note:

1. Linux kernel is upgraded to v5.3.6;
2. A much more stable open-source GPU driver (combined latest lima and mesa) is now available;
RetroArch is upgraded to v1.8.1;
3. Clockwork Warehouse is open (more details please check About Clockwork Warehouse part below);
4. Auto expand filesystem is available.
5. Known bugs fixed.
6. Heating may be lower, and the battery may last longer due to the upgrade of GPU driver.
7. Fixed bugs found in this thread.

KNOWN ISSUES:
LOVE2D may be unstable under GPU mode.

About Clockwork Warehouse

For Clockwork OS v0.5:

Through Warehouse, you can easily browse and download indie games. Thanks to the participants of former Game Jams.

We truly appreciate the spirit of gaming. We welcome all the game makers to share your works with us. Please send your works to warehouse@clockworkpi.com . We also have rewards for your great works.

Works of future GameShell Game Jams may be selected for the Warehouse.

Also, you can even build your own Warehouse to share your collection with the community. Instruction will be released soon on the forum.

About Auto Expand Filesystem

It is a convenient function that allows the users to change microSD card to bigger ones.

It will automatically expand the filesystem to match the real size of your microSD.

You just need to flash the Clockwork OS v0.5 into the microSD, then put it into your GameShell, and turn it on.

How to upgrade (Patch WIP, backup before use)

If you are currently using Clockwork OS v0.4, you can use a patch to upgrade to v0.5. This way of upgrade will not erase your files and records.

1. Download: 
    http://dl.clockworkpi.com/patch_for_clockworkos_v0.4.sh
    md5sum: b81fe1644303644cd2afde95c227734c
2. Type “sudo apt-get update  && sudo apt upgrade”
3. Copy patch file to GameShell
4. Run “patch_for_clockworkos_v0.4.sh” on GameShell

If you are using other version of Clockwork OS, you can upgrade to v0.5 by flashing. This way of upgrade will erase your files and records. Please make a copy before start.

1. Download:
   http://dl.clockworkpi.com/clockworkos_v0.5.img.bz2
   md5sum: 94b6b03e84488092553a8a09579b33f8
2. Go to “https://www.clockworkpi.com/faq >Getting Started>How do I recover/upgrade the MicroSD system (Clockwork OS)?” to see how to flash.
16 Likes

Thanks! I’ll be doing a clean flash of this tonight :heart_eyes:

Also it’s your cake day yong :cake: :tada:

After some testing:

  • The OP1 theme doesn’t work – it causes the Launcher to get stuck on the “Loading…” screen
1 Like

How do I download the upgrade patch? I tried copying and pasting the URL, but it sent me to the text of the .sh file instead of actually downloading it.

I did a wget through ssh. Worked pretty well that way. But then I tried using the update launcher in the settings menu and got that loading screen bug. So I’m going to flash brand new :sweat_smile:

Also, the forum is telling me this is your first post, so welcome!

Launcher is stuck on the loading screen after upgrading from 0.4 through a patch.
It seems that pyaria2_rpc.pyaria2 module is missing.

1 Like

How do you flash without losing all the data previously stored on the device? I’m kinda afraid of having to take it apart because I’m worried I might accidentally mess something up. Also, is there anyway to flash without removing the sd card from the Gameshell? I doubt there is, but I figured I’d ask just in case.

I just took my device apart. I don’t actually know myself how to flash a card that way, I only know how to do it by putting it into another computer.

For not losing the data, you can copy the files onto another computer that you want to keep, then move them back afterwards. That’s the only way (for fresh flash) that I know how.

1 Like

Fresh install, booted GS, tried to change the theme and now I’m stuck on loading screen again.

By the looks of it the OP1 theme is broken for now, so reflash and avoid it!

Is there a way to revert themes from ssh?

So, the patch isn’t usable right now, correct?

Remove the file .gameshell_skin in /home/cpi:

rm /home/cpi/.gameshell_skin
4 Likes

Correct. It wasn’t for me anyway.

@Nathan_Lee
I used ssh and curl to download it directly on to the GameShell. But it seems to have broken X11 and the GameShell is stuck on the “Happy Hacking!” screen.

@yong It looks like the new video driver crashed. Here’s the log:

[ 95.221] (II) Loading sub module “glamoregl”
[ 95.221] (II) LoadModule: “glamoregl”
[ 95.222] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[ 95.245] (II) Module glamoregl: vendor=“XdotOrg Foundation”
[ 95.246] compiled for 1.19.2, module version = 1.0.0
[ 95.246] ABI class: X.Org ANSI C Emulation, version 0.4
[ 95.246] (II) glamor: OpenGL accelerated Xdotorg driver based.
[ 95.302] (EE)
[ 95.302] (EE) Backtrace:
[ 95.302] (EE)
[ 95.302] (EE) Segmentation fault at address 0xbc
[ 95.302] (EE)
Fatal server error:
[ 95.302] (EE) Caught signal 11 (Segmentation fault). Server aborting
[ 95.302] (EE)
[ 95.302] (EE)
Please consult the The X.Org Foundation support
at wiki.x_dot_org
for help.
[ 95.303] (EE) Please also check the log file at “/home/cpi/.local/share/xorg/Xorg.0.log” for additional information.
[ 95.303] (EE)
[ 95.315] (EE) Server terminated with error (1). Closing log file.

1 Like

After installing the script and rebooting, it stalls before login with the message “You have mail.” I am able to SSH into the GS. Is there anything I can do to fix the boot?

Thanks!

ssh into gs

cd launcher
git submodule init
git submodule update
1 Like

for video crash after upgrade script
maybe try to run
sudo apt update && sudo apt upgrade

the tutorial has missed sudo apt upgrade

or

can do the whole job for you

1 Like
sudo apt update && sudo apt upgrade

try to upgrade once

2 Likes

Does this work in terms of getting the upgrade patch to run correctly?

yes, you are right …

1 Like