clockworkpi

MAME and FBA vertical games RetroArch aspect ratio issues

Ok so here’s the thing,
I use my GameShell mainly for Arcade games. I use MAME but I prefer FBA for most of them. So I plsy horizontal games but also vertical games and this is where is my issu. All vertical games are cut off on top and bottom.

I tried almost everything (at least I think I have). I tried all aspect ratio, I tried Custom Height and Width in Retroarch but it does not work since, for some weird reasons, with or without Crop Oversan, the screen is cut-off when I try to center the content.

Why is it like this? Why can’t I center the content when I use Custom Aspect Ratio?
Any Idea?

There was a discussion about this in “Mame standalone” thread. I think it is connected to the Retroarch optimization with current video drivers setup (on OS 0.4). Because I managed to install RA 1.7.0 from OS 0.21 onto OS 0.4 and this issue was gone, but unfortunately other issues appeared (for example SCUMMVM core stoped working for me).

Would there be a way to “force it” in RetroArch?
Because its kind of a big issue. Since the GS support MAME and FBA, it should at least show us the right resolution or allow us to set it manually without problems…

I tried everything iI could, and I’m not a professional at all of this, but I failed to make it work right :face_with_head_bandage:

Ok well then we need help from ClockworkPi or RetroArch directly?
Is this a RetroArch image made just for the GS or is it straight from the source?

It was taken directly from OS 0.21 (file by file)

Ok but is this RetroArch image vanilla or was it modified by ClockWorkPi?

I flashed fresh OS 0.21. Copied every RA related file from file system. Erased and flashed fresh OS 0.4 image to card. And replaced stock 1.7.7 RA files with files of RA 1.7.0 from OS 0.21.
I don’t know what is vanilla, as I said I replaced RA files on OS 0.4 with same files from 0.21 which have stock RA 1.7.0

Vanilla mean its straight from the source.
My question is that I want to know if I try to contact the RetroArch dev team about my issue, or if I contact ClockworkPi about my issues because THEY modified RetroArch to make it smooth on the GameShell.

Could it be for arcade games that expect either a 1:1 ratio, or possibly even a 3:4 (as opposed to a 4:3 ratio)

Eg, Gunbird. Using vanilla settings, it is cropped on the top and bottom.

Changing the aspect ratio width to 240 and height to 240, I get a 1:1 ratio. It’s a squashed image but I can live with it, rather than having to hold my console like a wonder swan. (In which case you could rotate the image 90 degrees)

Here’s some before and after shots, in particular highlighting the crop.

Sorry; Pictures are bad because I’m posting in bed ;). Don’t want to wake the lady.

Also I don’t think clockwork people actually touched retroarch. If anything, it would just be the config file that have a default driver set and input binding set to get it initially working. Perhaps some default directories. Other than that, it’s all core settings. I could be wrong. But I usually reconfigure EVERYTHING from scratch, so I know exactly what has been set.

I’m on clockwork OS 0.4. This is Retroarch 1.7.7. Haven’t upgraded fo 1.7.8 yet. Might do that now. Using the mame 2002 plus core.

I am pretty sure they did modify it, or there is another issue with OS 0.4 or the Lima drivers…
I installed a stand alone version of MAME and I do not have this issue, When I launch a vertical game in there I can see the entire portion of the game, its not cut on top or bottom and its centered on the screen.

Right now, when using RetroArch, on the GameShell, if I try to get the 3:4 ratio I can set it manually with custom ratio, but the issue then is that it prevent me from centering the content. If I try to center it it gradually cut the right side of the said content. This does not happen in the stand alone MAME.

When you do an upgrade, you’re pretty much getting a vanilla installation from retroarch directly. You’ll just need to rejig your config file accordingly.

I just set my custom aspect ratio X position to 40 to centre my image. It appears to be fine. I am however using a custom resolution of 240x240, as opposed to 320x240. Given the screen is 240 pixels high, trying to fit 320 in doesn’t usually work well. It’s distorted yes, but at least it’s not cropped.

Another thought! Try switching back to the FBTurbo GPU driver.

Yes with FBTurbo it works so its a Lima issue then.