MAME seems to crash

I have put my ROMs (in .zip format) in ~/games/MAME and they get recognized by the gameshell
but when I try to run them (after the automatic setup) the screen just goes black for a few moments and spits me back to the main menu.
I tried removing and downloading MAME a few times (through the RetroArch cores manager and the “automatic setup”)
and still same result.

I don’t know what the error is exactly as I do not know how to access the logs.
Im pretty sure my ROMs are not the issue as they seem to be in the right format (tried 4 different ones)
but if you have testing ROMs I can try them too.

thanks in advance.

P.S: I saw on another post someone was recommended to use FBA instead but if its not a hassle i want to specifically try to fix MAME first as it was the emualtor installed by default

You need to have the compatible roms as well - as not all MAME roms will work with emulator. A quick internet search should be able to help here.

I am currently running these two emulators, and not having any issues: