Mame2003_plus_libretro.so.zip download failed

Hi,
whenever i try to setup a mame game, i get the error message “download failed mame2003_plus_libretro.so.zip”.
where can i get this file and how must i install it?
Thanks in advance
Torsten

1 Like

https://buildbot.libretro.com/nightly/linux/armhf/latest/mame2003_plus_libretro.so.zip

You can SCP into the gameshell and place the UNZIPPED file in /home/cpi/.config/retroarch/cores
Yes, .config is hidden folder if you have difficulty getting to it from within the gameshell.

If you aren’t using Retroarch, and are trying to use “MAME” from the “Retro Games” folder, place the ZIPPED and UNZIPPED file in /home/cpi/apps/emulators.

1 Like

Thank you,it works. I tested some Mame games.
(One little problem: the screen is very small, some games are very difficult to play)

how did you do that? I’ve a mame game I want to try, and in the page “Load content” of retroarch it tells me it needs mame2003-plus core to work. So I downloaded the core, I placed it in both /home/cpi/.config/retroarch/cores and /home/cpi/apps/emulators, but when I run it (from “MAME” in retro games and from retroarch) it crashes… I have the same problem with nestopia games, so I don’t think it is the game damaged (but gba works well)

Hello,
i also had some crashes, but some games are running. Probably not all games are compatible. I had the same experience with Mame running under Windows.
Hope you find some nice games which work
Torsten

1 Like

I haven’t been able to play a single game. That makes me very sad.
I tried what was described here RetroArch Megathread no success
I can connect via ssh but can’t seem to upload anything :frowning:
And all .so downloads fail…

for the time now

git clone https://github.com/cuu/emulators.git ~/apps/emulators

make a little bit convenient for downloading emulators’ .so files

PS:
I found out at this moment, libretro.com clears all .so files on /latest/ location
this will cause every emulator download so failed

We will have a new update very soon to fix this problem

Oh no, It seems something has failed with libretro buildbot:
https://buildbot.libretro.com/nightly/linux/armhf/latest/
Try this path:
https://buildbot.libretro.com/nightly/linux/armhf/2018-07-25_cores/

Hello tart2000,
here a step-by-step description how to start playing mame under menu Retro Games (not RetroArch):

at CPI:

  1. get the IP-number in menu TinyCloud

at PC:

  1. Download of mame2003_plus_libretro.so.zip, i.e. here
  2. Unzip to mame2003_plus_libretro.so
  3. get your mame ROM (from wherever) as ZIP file (i.e. Pacman was running at my CPI)
  4. Dowload a SCP-Software (Windows has none), i.e. WinSCP and install it
  5. Start WinSCP and connect to CPI:
    File protocol: SCP
    Host name: IP number from step 1.)
    Port number: 22
    User name: cpi
    Password: cpi
  6. copy mame2003_plus_libretro.so from PC to CPI /home/cpi/apps/emulators
  7. copy pacman.zip from PC to CPI /home/cpi/games/MAME

at CPI:

  1. start menu RetroGames>Mame
  2. if the game isn’t there press X to scan
  3. select game and press B to run

In my experience MGBA games run better, especially they are easier to play at the small display. Many mame games don’t work and crash at startup.

To play MGBA, you have to unzip them and simply copy the GBA files to /home/cpi/games/MGBA.

Good luck and good fun
Torsten

3 Likes

LOL, chill down, it’s all fixed, I forced a rebuild of everything that’s all.
Also you should use the builds from here instead

https://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest/

Those are optimized for cortex-a7 neon. You would have to change the url in the config file manually.

1 Like

I’m in the matrix!
It managed to download the right .so on its own.
Thanks a lot for the good work.