NEOGEO games not working


#1

Has anyone had any luck with getting NEOGEO games to work?

Mane doesn’t work for me

Any suggestions help would be great, thankyou


#2

what core are you trying? and what versions of ROMs are you trying? Are you trying to get FBA running? I tried, but to no avail, so I found a serviceable alternative…

I am using the MAME core that came pre-loaded, and a set of v0.78 MAME ROMs. There are many NEO-GEO games amongst them. I have Metal Slug 1,2,3,4 and Neo Turf Masters running correctly.


#3

Yes I tried the inbuilt one, I did try fba, but no luck like you.

I didn’t realise there were neogeo games amongst MAME sets, I have a set of ‘NEOGEO’ roms, but if I’m honest I have no idea we’re i got them, it was years ago. So no idea wheather they are mvs, aes or cd haha


#4

ah yes thats your problem, unfortunately MAME and FBA ROMsets have to be of specific versions to work on particular versions of emulators. The MAME core that comes on the pre-installed image (MAME 2003, I believe) is compatible with v0.78 MAME ROM sets, much like Retropie. Obviously I am not permitted to share any links to downloads here, but a popular web search engine will point you in the right direction.

Finding the NEO GEO games amongst the MAME sets is pretty easy when you know what to look for. the ROM file names will be the same as in the NEO GEO sets. There are a couple of hundred, by my reckoning.

fafury,
mslug
mslug2

etc

are what youre looking for.

NEO GEO MVS and AES are basically the same thing, by the way, on the actual hardware, the same ROMs would work on either device. NEO GEO CD games run off different cores again, and to be honest, you’re not missing much there.

Make sure also that if you are trying to run NEOGEO games, you have the complete appropriate BIOS sets. However, MAME doesn’t need them.

Finally, as an aside, if you are a fan of the Metal Slug franchise, take a look out for In The Hunt (file name: inthunt), it’s made by IREM, but by the people who went on to design Metal Slug. It’s really rather good.


#5

Thankyou for your help! In that case I embarrassingly already have them working ! Or most of them anyway, some are temperamental.

Funnily enough I just acquired that game for psx!

I love the metal Slug series so look forward to trying that

Thanks for your help mate!


#6

Seems a few work, most do not unfortunately. Hopefully a solution can be found at some point!

At least one metal Slug works so that’s cool!


#7

I’m using the FB Alpha core. The neogeo bios is in the system folder in the retroarch folder (i used the Retroarch Megaguide here to set up the directories). This was the easy bit!

The hard bit was setting up my romsets. The way I managed this was to use Romcenter to check my roms and fix them if the roms were named incorrectly. You need to have a DAT file that is for the version of FBA (or Mame) that you are running. I compiled various different versions of romsets for different machines that I was running them on. The set I use for th GS is the same romset I use for my GCW Zero. If I remember correctly uses the MAME 0.159 romset.

I haven’t tried the neogeo games on the Mame core yet, but FBA is running it really well. I just need to work out how to get to the dips and turn on the ‘red blood’ option on the Metal Slug games :grin:


#8

Where did you get the fba core? Is that a .so file? Because I couldn’t find that anywhere! Also where does the DAT file go? And what is it haha.

To get to the dip switch I press one on my light key buttons (which is set up as r1 or r2 I believe)!


#9

I use Mednafen NeoPop. I only have 3 titles for it but they all work fine.


#10

They are neogeo pocket games, which thankfully I got all setup and working great.

It’s the arcade titles that are causing issues!


#11

If you go into settings during a game you should be able to find an option to set how to go into service mode.


#12

To get the FBA core, load Retroarch, go to Online Updater, then Core Updater and select the core you want to download. At the moment I just use FB Alpha, but I also have the CPS-2 one that I use for CPS-2 games (haven’t checked to see if there are any performance differences).

A DAT file is basically a list of games with the correct individual rom names and checksums for that game. You use a program like Rom Center to scan your roms and it will verify if your collection is correct for the DAT file you select. If there are any issues like incorrect naming, Rom Center will rename it. Problems can arise if you are missing some of the individual roms from within your game zip. Finding the game that is the correct version that you need can be very hit or miss.

That is a really basic description of DAT files. ClrMamePro is another really good program to use to audit your roms, but I found Rom Center easier to use.


#13

Thanks for the great reply! Sorry to be abit stupid but is the DAT file something I go and ‘find’ or is it something retroarch creates when you download a core?

I think I might be about if luck with those two programs, I’m on a Mac. Doesn’t look like they have support!


#14

https://github.com/HerbFargus/retropie-dat/tree/master/lr-fba

Pretty sure I used the FB Alpha v0.2.97.30 DAT file to audit the roms I use for the FBA core.

As for Mac support, not sure. Found this, hopefully it turns out to be helpful.
https://www.emulab.it/forum/index.php?topic=104.0