Manjaro Linux support

That’s awesome! I am wondering if the screen tearing(like scrolling up/down in a browser) improves under sway?

1 Like

it does! i love my sway setup on DT

3 Likes

I’ve burned sway image and I have rotated display.

What to change in configuration?

1 Like

In sway I have to check but in kde settings there is a way to rotate the screen.

Hello @AlexDuan
I have written an email to you regarding the issue i have with my lcd screen. The backlight doesn’t work.

I’ve suspected it to me broken lcd backlight flex cable.
I have also sent images of the same.

Did anyone else in the community faced similar issue with backlight?

1 Like

rotation should be fixed for Wayland in the latest kernel images from the Manjaro “testing” repos. I suspect you are perhaps running an older kernel. It should also be correct for X11 as long as you have “clockworkpi-a06-post-install” installed.

check this thread:

1 Like

Still no proper rotation

Linux devterm 5.16.1-1-MANJARO-ARM #1 SMP PREEMPT Sun Jan 16 08:42:28 UTC 2022 aarch64 GNU/Linux
1 Like

No update was done to the kernel with respect to Devterm A06 rotation.

If the drivers are present then you will need iio-sensor-proxy and other user space library to make it work.

1 Like

@spikerguy there were some changes between when Dan initially built dev images and when he pulled in the latest history from my kernel tree. panel rotation is now set in devicetree and the cwd686 panel driver now but not sure that made its way into any of the dev images.

It just sounds like Sway isn’t using the panel driver’s orientation or something (GNOME on Wayland works fine, so unclear where GNOME is doing something special here or Sway is)

I don’t think that there are any accelerometers or sensors at play that would be aided by iio-sensor-proxy

1 Like

Ah ok, I though there is an accelerometer for auto rotate. I have not seen the schematic yet.

1 Like

Hey All,
Received a working LCD and I am impressed by how well the default os which is Armbian is working. Just tested the headphone jack and it seems to work fine and autodetect seems perfect to me.

I see it is Kernel 5.10 which is mainline LTS. I am testing power consumption via USB it is 5.22V and 0.700Amp which is around 3.6W approx.

I will test Manjaro ARM images and see how well we handle the audio jack function.

3 Likes

The audio jack function should be working now, I submitted some additional packages to Dan last week, along with ALSA UCM config changes for clockworkpi-a06-post-install.

Forgot to update here, sorry about that!

2 Likes

Yes just tested KDE PLasma image and it worked like a charm.
Now I am looking at sleep mode so we can put it to sleep instead of power off and on again. I will get some batteries tomorrow for testing.

I’d be curious to know how you fixed the screen rotation issue. If there are other things you configured that would be interesting to see too (if you don’t mind sharing parts of your config file or pointers.) I’ve never used Sway before, and from what I’ve see it looks interesting. But I also haven’t found any good overviews or tutorials yet (most everyone just points to the man pages, which I guess I should read!)

I did manage to rotate my screen properly after login, using the sway wiki as a guide and changing the config file to include output DSI-1 transform 90. Thing is, that only affects rotation after logging in, so the login screen is still rotated.

I’ve noticed a few other lower priority things that don’t work, like being able to use the FN and <> keys to change brightness, and the FN and volume key to change volume. There’s probably a way to set that up in a configuration file or utility somewhere, but I have no idea what I’m doing right now, so I’ll have to do a lot of stumbling around and research to find out. :slight_smile:

Also, the battery indicator seems to be wonky. It’s showing I’m charging when I’m unplugged. And default sizes of some windows/panels have too short a height and show an error instead of displaying (like when clicking on the processor icon). I realize it’s still a work in progress and I’m not complaining – mostly just somewhat confused and interested in figuring out how to use Sway. Definitely seems fast and stable right now on DevTerm for the little bit of checking it out I’ve done. It also seems quite appropriate to run on the DevTerm, with it’s minimalistic text/icon presentation combined with speed.

that output DSI-1 transform command is exactly how i did it, and yeah it doesnt work on the login screen either. FN volume and brightness just comes down to setting the bindings in sway config

1 Like

For login screen put line

output DSI-1 transform 90

in file /etc/sway/outputs/default-screen

2 Likes

Just to confirm that the current Manjaro builds do not include the fan control python script, right?

2 Likes

Correct. Packaging for the python control script is tricky due to relying on some custom wiringpi patches, etc.

Though I’m hoping to find time to submit a patch for kernel-based fan control this week

2 Likes

Did you ever track this down? I’ve been doing things with the printer and leaving it plugged in. I actually cut some little paper squares to drop in on top of the speakers (blocking the signal contacts) to disable them until I can get the noise killed :pouting_cat:

btw I’m running the stock OS, getting the same issue and looking to switch for unrelated reasons

1 Like

Nice work! I just installed the latest test release and it seems to work smooth. However I think the screen blank issue is still there. In the xfce at least after some time the screen seems to blank and after pressing a key or moving the pointer only the backlight will turn on.
Also I found a couple of other issues (maybe not related to the Manjaro port) that I want to mention.

  1. sometimes when switching the DevTerm on/off there is a loud “plock” coming out of the speaker. When I was running just from USB power this “plock” sometimes even switched off the device immediately.
  2. When the device is powered off forcefully by pressing the power button until it goes off, the next time I switch it on it is not coming up. I need to switch it off again and power on again. However, I can prevent that situation when I remove the batteries after switching it off. When I plug them back again the device will come up normally.
  3. Suspend to RAM is still not working.
  4. When powering down the batteries still drain. You can see that when switching it off with full batteries in the evening and powering up in the morning.

I want to help if possible but last time I build the kernel with the manjaro arm tools it took more than 12hours on my laptop. I could push it down to 4 by reducing the kernel config but still this is too much. This is probably due to the qemu emulation for each build step and the weak hardware that I own.
Is there a way to cross compile the kernel for manjaro?
Maybe even somebody tried to compile it on the device itself and replace the kernel and device tree and can share the steps how to do that?