clockworkpi

Missing libbcm_host.so when start Minecraft Pi

I’m trying to run Minecraft Pi on GameShell, after doing a lot of searching and installed most of dependent packages, I’m still get this error when I execute ./minecraft-pi
./minecraft-pi: error while loading shared libraries: libbcm_host.so: cannot open shared object file: No such file or directory
I tried to get this file on https://github.com/raspberrypi/firmware/tree/master/opt/vc/lib put it in /usr/lib and run sudo ldconfig -v and it shows libbcm_host.so -> libbcm_host.so but still got the same error when I try to run Minecraft Pi.
It seems to be part of some Raspberry Pi‘s package, but I can’t find a way to install Raspberry Pi package on GameShell. Any solution?

bcm_host is the Broadcom hardware interface library which is specifically for RaspberryPi hardware. I don’t think installing the .so file will do anything to GameShell since it has no relevant hardware.

This is a common problem for other Raspberry Pi releases too. I tried these a while back (they appear to have been removed now?), and they all gave the same error:

I’m curious if some of the Raspberry Pi applications would work if some kind of stubbed out version of bcm_host was available. I wonder how many actually use something in it, and how many are just linking against it because it’s standard practice to do so in the Raspberry Pi world?

1 Like

They seems find a way to get it working, I wonder how they did it.

1 Like