My GS doesn't turn on

Hello! I have a problem with my GS. I got the product today but I put it together and it does not turn on the console. The green light turns on for a few seconds and goes out.

  • I armed and disarmed the consoles several times: there was no solution
  • The SD card is in good position: there was no solution
  • charge the product several minutes: there was no solution

Any idea what the problem is? I’d appreciate your help

If you have another microSD card, try installing the GameShellOS image onto it and try running with it. If you don’t have another card, just install it on the original.

If the image is corrupt on the card, it will behave as you describe.


GameShell OS image file

1 Like

Check the screen connector, I had the same problem when I first assembled my GameShell, dismantled it and saw that the screen cable was not “locked” correctly, the black latch was not in its lock position. So give it a look it might be the same problem.

I am testing with a 128 GB memory using the Etcher program in Windows to install the image. It’s compatible?
I tried reinstalling the image with Etcher in the 8 GB memory but there was no solution. The green light goes on for a few seconds but the screen goes black.

Can you send me a picture of the position of the connector on the screen? I hope it is not annoying. I would appreciate it

Etcher should work fine to copy the image to any 8GB or larger card. The result would work fine to test things, but would appear as an 8GB memory, regardless of the actual SD card’s size. If you want to expand the image to fill the card, use a bootable gParted USB drive or most any Linux “Live CD” with gParted to expand the image to the available space.


I found a new 8GB memory, installed the image and nothing. The problem was not solved. I send the photos of the connections and the problem (I know that the keyboard is missing)

oiuououo jkljklj jkljkljljl tyutyuru j%C3%B1j%C3%B1i uiliuu

Are all the pins you are putting the cables on still straight ? Could be an issue if it was put in to strongly earlier…

You don’t need the battery or speakers attached either for testing, if you have USB power. Have you tried pressing the reset button (sw2) on the opposite side of the logic board with power attached?


The screen connector latch looks ok from the pictures posted above

Yes, I press it and nothing. Maybe I’m badly installing the image in memory. What other program for windows can I use? Which are the steps to follow?
It would be the last option to try. Or I will ask for the product change

Thanks for your help. I appreciate!

Captura|690x98 Captura8 Captura5Captura

This two work the best for me:

When you attach the USB, does the green light turn on and remain on or does it turn off after a few seconds? I determined with my own that the light doesn’t turn on at all if there is no valid microSD card inserted. If it stays on, you may have a defective logic board, since it should turn off during startup and turn back on yellow until the battery is fully charged. If it seems to be working properly, try examining the display with a bright flashlight to see if anything is on the display. If there is, you have a defective backlight on the display. if not you may have a defective display or display cable.


Hello. I took the Gameshell back out of the box to try to solve this problem. I could never get it to work. I’m about to try to download the new version of the image and see if this would solve the problem.

Just turn on the green light when connecting the motherboard with the usb cable. But nothing is visible on the screen

Wish me luck

OG Kickstarter funder having the same problem.

I tried updating my Gameshell OS the other day via Wifi and looks like the OS got corrupted during the install. When I opened up the Gameshell, the LCD cable popped off. When I reconnected all the cables, it stopped turning on. I’ve charged the batteries, left it connected to USB but I don’t even see the LEDs flash.

I’ve re-formatted 2 different 8GB cards using Etcher but neither to get the LEDs to flash or stay on.

Any ideas?

Fixed. Seems I had to reflash an SD card with a full successful validation.