Batteries won't charge

After a long wait my uConsole arrived, I assemed it on an antistatiic mat with. Lth the mat and the wrist strap grounded to house ground. I popped in those Samsung 35Es I bought around the same time I ordered the uConsole, but later after hours of use while on USB-C I learned the uConsole wouldn’t charge.

If I remove the USB-C cable it immediately dies.

  1. Shutdown and opened the unit up. The battery board appears seated correctly and the batteries polarity-wise are in correctly.
  2. Closed the unit back and searched the forum, I learned of the need to apply the charging patch, so I applied the canonical patch to charge the batteries faster hoping that would fix things, stopped, restarted the unit – the Gnome Battery Applet battery icon slowly rotated through yellow with a red lightening bolt through to a solid green battery icon over and over .
  3. Left it charging ( err. The USB-C connected ) the night gambling my house wouldn’t burn down for the night and it was the same icons toggling back and forth. Disconnected the USB-C cable and the uConsole died.
  4. I shut the unit down, popped out both batteries and each measured approximately 3.5 volts. Each different. Some of the posts meantioned fake 18650 batteries – I don’t remember where I got these batteries from so I just ordered two Samsung 35E 18650 3500mAh 8A batteries from the 18650BatteryStore.com for a little over $13. I couldn’t justifying paying $30-some at my local Batteriesplus.com store.

Thoughts?

Is there any way to know for sure from the command line the batteries are charging… I tried a number of commands from the forum, but they seemed to just print out data from Gnome Battery Applet… I was wondering if there is something lower level?

73

I think you either have a pair of duds or a faulty battery board. When I installed my batteries (Samsung 35Es from 18650BatteryStore.com) I was able to immediately power the device on without it being plugged in.

Theres a line of code that solves power/battery issues in this thread, everyone had an issue with power but was solved after putting this in, might help with your problem. I think its just a fault in the programming clockworkpi put out.

Yep. @Snoozer94 I tried the patch with step-2. That didnt work, but I think @mikeschnier is correct.

I either have a pair of dud batteries or a faulty battery board.

The patch will be helpful later.

Powering it on with batteries alone has never happened. Hmm.

Two new batteries from a reputable dealer hasn’t resolved the problem. I have contacted Clockworkpi.

Solved!

The instructions tell you to screw the battery board down, but to not snap the battery board’s connector into the connecter on the board above it. Merely screwing the battery board down will not complete the connection. When I pressed the battery board’s side of the connector down it made a satisfying click and I knew immediately this was my problem. In hindsight it is plainfully obvious but not the several times I reseated the battery board. A few hour later my battery was fully charged.

Just don’t do as the picture shows. Push the connector down to complete the job.

1 Like

don’t press the connector straight down, insert at a 45’ angle then lay the board flat. you can bend and mash the female part of the connectors.

IIRC, I just screwed it in and it was fine but there’s probably some variance in manufacturing. An extra half millimetre here or there that might require a bit more work to get a good connection.

@Rex good to know. The pictograph for installing this board is but lacking these nuances.

OMG, I did not do like here on this photo, but like that lazy manual suggested