clockworkpi

Need help with Zandronum for Doom Wads and PK3

So since OS 0.4 I have issues compiling ZDoom. Nothing changed with OS 0.5.
But I managed to compile Zandronum.

The issue I have is that when I launch Zandronum, it load correctly but when I go in the menu and select New Game, it go back to the GS launcher (so it crash).

I have doom2.wad in a folder along with a Doom2.sh containing the following:

/home/cpi/zandronum/zandronum -iwad /home/cpi/launcher/Menu/GameShell/22_Natives/DOOM/doom2.wad

Can someone with more experience try it?
Here is the source I used: https://bitbucket.org/ptitSeb/zandronum/src/default/

I finally managed to compile ZDoom using:
git clone https://github.com/rheit/zdoom.git
cd zdoom
cmake . -DNO_OPENAL=ON
make -j4

So I will test and maybe Zandronum will become useless…

1 Like

Wow. That’s far less than what was involved previously! Well done!!! :smiley:
I guess it wasn’t completely useless, since it motivated you to try something else re: Zdoom.
I’m guessing you sorted out all of your sound issues as well? To think, such a simple parameter of .-DNO_OPENAL=ON would do the trick. Makes sense!
Did you have a swap file installed while using make -j4?
I’m going to go ahead and try this out!

On a side note, you’re keeping the wad files in:

 /home/cpi/launcher/Menu/GameShell/22_Natives/DOOM/doom2.wad

Would if possibly be wiser to keep it in:

 /home/cpi/apps/Menu/GameShell/22_Natives/DOOM/doom2.wad

Just to keep launcher items that get updated separate from user created content, and for consistency? It will work either way, but just trying to keep tabs of things can become an auditing nightmare.
I’m just looking at the old legacy file references from the 0.2 file structure days, and fear inconsistencies down the track.

Well, sound is off in fact. Its weird because on OS 0.3 I did not have this problem.
I am using the same source as before: ZDOOM on GS for Brutal Doom and other mods!

I will try to find out what is the issue but its still all very cryptic to me.
Did something changed with the sound drivers in OS 0.4 and 0.5 ?
Does the GS support FMOD ?

Also, I was able to get SOME sound working (only the music), by setting the sound playback to Timidity++.

I do not understand why this is so complicated! It was ok on OS 0.3 but since OS 0.4 its not. The dev could help me with this!!!

When I try to compile without turning OPENAL off, I get this error:

[ 54%] Building CXX object src/CMakeFiles/zdoom.dir/b_func.cpp.o
/home/cpi/zdoom/src/sound/oalsound.cpp: In member function ‘virtual SoundStream* OpenALSoundRenderer::CreateStream(SoundStreamCallback, int, int, int, void*)’:
/home/cpi/zdoom/src/sound/oalsound.cpp:1298:41: error: ‘mem_fn’ is not a member of ‘std’
         StreamThread = std::thread(std::mem_fn(&OpenALSoundRenderer::BackgroundProc), this);

I am trying to follow the steps here:
https://zdoom.org/wiki/Compile_ZDoom_on_Linux

Is it possible that the issue is that it tries to make me compile with an unsuported version of OpenAl or Fmod on the GS?

std::mem_fn => https://en.cppreference.com/w/cpp/utility/functional/mem_fn

=> #include <functional>

=> https://forum.zdoom.org/viewtopic.php?f=7&t=59609

1 Like

ok lol
Its too cryptic for me.
What do I need to understand here ?
How do I add mem_fn header to oalsound.cpp ?

apply the commit, add the header file :
#include <functional>

Thanks r043v but I never did that.
What would my compiling text look like to do that ?
Is it git checkout [bdfc421] or something like that…

Salut r043v j’avais oublié que tu parle Francais.
Comment j’inclus un commit quand je compile ?
Est-ce que tu peux me donner un example ?

édite le fichier et insère la ligne directement, c’est le plus simple :slight_smile:

si tu utilise ce git en particulier, oui tu peux faire un git checkout vers un hash de commit

Dans oalsound.cpp directement ?
Et ce fichier il serait ou dans le tree du GS ?

I don’t speak french, but this might help?

2 Likes

dans le fichier src/sound/oalsound.cpp

1 Like

Ok merci à vous 2 je vais essayer ça de suite!
Thanks to you both, I’ll try that right away!

Congratulations!! It seemingly all works now! I am running doom, using openal for the sound effects, and timidity for the midi.
It’s all working the way it should!
How are you going with it?

1 Like

Well it compile great for me but as soon as I press new game it revert back to the GameShell menu.

Same thing over here. Funnily enough, when you don’t enable OpenAl, it works fine. So close. But so far.

lol… I know! My head is about to explode.

AHA! Try disabling EFX in advanced OpenAl settings. It’s working for me.

2 Likes