clockworkpi

No internet when connected on USB

I manage to connect on FTP or SSH with USB interface on 192.168.10.1

But I can’t access to internet. Can you help me please ?

You need to enable Internet Sharing in your computer’s OS to the RNDIS interface. I use a Mac, and have previously covered the setup in this discussion. In Windows 10, I believe this would be handled through the settings in Settings > Network & Internet > Mobile hotspot .

Hi @lasvegas,

Yes I saw the thread. But I can’t manage to share the connection… I tried to create a bridge between my Ethernet connection and RNDIS interface. I tried to share the ethernet connection too :

no luck

I can’t access to the Gameshell anymore on 192.168.10.1

If you haven’t already, you should set up the RNDIS connection with a static address:

IPv4: 192.168.10.2
Mask: 255.255.255.0
Gateway/Router: 192.168.10.1

This should assure that your GameShell has a viable connection to pass the network through.

I believe your GameShell would have the IP address: 192.168.10.10… I might be wrong here though…

I’m using Windows 7 and can’t get the internet to work. I set the ethernet connection to be shared and added the static address (which caused the internet on my regular computer to fail).

Has anyone here got it to work?

Settings->Network gateway switch->USB Ethernet ,make sure it is selected

That’s already enabled. Transferring stuff between my PC and the GS is also no problem, only the internet sharing doesn’t work.

I got it working, I had enabled sharing for the wrong network (the ethernet one instead of my main internet connection).