Possibly dud screen - SOLVED

So apart from the missing RPi CM4 Lite adapter board, it looks like I may have also ended up with a dud screen. I borrowed the adapter board from my Devterm kit, put everything together including the flashed-with-latest-image TF card, plugged it into charge with fresh 18650 cells, and I get zilch on the screen when I turn it on. I can see the green LED light up on the board near the switch, and I feel the RPi CPU warm up, but I don’t get so much as a flash on the screen. I’ve reseated the screen cable, but it hasn’t had any effect. I have an email out to Alex, but if the community has any ideas, I’d love to hear what else I can try here.

Note: the micro-SD TF card in my device simply wouldn’t go in via the slot in the casing, I had to dismantle the whole thing to get the card inserted. The aperture may need some filing to get it wide enough to insert the card.


About the adapter, a few posts ago I saw Alex commenting that there was a mixup in the factory and they are going to send to those who didn’t get the adapter. There was an email you need to send…

Yes - Alex reached out via email to confirm this and is shipping the board out to everyone affected it seems.


i met the same problem last day, i did everything you did… but it get working when the corebord was fully inserted and you can not see any part of the gold fingers.

the correct one.


Appreciate the heads-up! No such luck at my end however - the adapter board is firmly seated with no gold pins visible. To be sure I pulled it out, swapped the CM4 module for another one, and reseated it similarly - same results. The CM4 CPU module gets warm, but nothing on the display.


If the screen doesn’t light up, it might be you don’t have the TF card image right - I’d say that is more likely than the screen being broken. If you don’t have the correct build installed (or the card is faulty) the screen will look dead. I know, as I tried the CM4 build with a A6 core CPU just to see what would happen. Nothing. Looked dead. One little green LED, that’s all. What do you see if you connect the external HDMI connector to an external display?


Hm - good to know. I’ll try reflashing the image and rebooting. It did occur to me to try the external HDMI display going, but I need to locate a micro-HDMI connector first.


So it turned out I misread what the RPi CM adapter supported - I was using CM4 modules with EMMC on-board (but without an image), which apparently disables booting from the SD card. Once I switched to a CM4-Lite module without EMMC, it all magically started working.


Tip: if you can somehow get the emmc flashed, it’ll run much more smoothly than microsd…

Remember to post a how-to for others if you do manage it though! :grin:


A setup with os on emmc and sd as storage is the best setup.

I’m pretty sure I’ve read on the forums, and perhaps the official website too, that the SD is inaccessible when using a CM4 with EMMC. That’s the tradeoff. It might be faster but you’re limited to only using the built in storage. I suppose you could mount a USB drive for storage though.

Also, there’s no way to flash the EMMC with just the Devterm/uConsole. You’d need to buy a separate board (not from ClockworkPi, but there are devices available online).

How do you know if you have emmc on cm4? I know mine is the lite version

Edit update

Does my CM4 have eMMC?
The Raspberry Pi Compute Module 4 (from now on abbreviated as cm4 ) has 2 versions, a lite edition without eMMC storage and one with onboard eMMC storage. The lite edition supports booting from an SD card, the eMMC edition does not.