Python IDE for DevTerm?

I’m curious to see if there is a lightweight Python IDE for Linux anyone knows that would run reasonably well on the DevTerm. I do a lot of automation scripting at my job, and if I could just SSH into my main box at the office and transfer the py file to the automation workflow when I’m not at the office, life would be awesome.

1 Like

My first idea would be NeoVim.

There are interesting distributions out there, like AstroVim GitHub - AstroNvim/AstroNvim: AstroNvim is an aesthetic and feature-rich neovim config that is extensible and easy to use with a great set of plugins, which basically bind a lot of vim PlugIns together.
Of course: the less PlugIns, the lighter

That would mean working in the terminal.
What could be faster? (Serious question)

1 Like

I like what I see, it merits further exploration for sure.

1 Like

I’m confused. IDE … SSH? IDE means different things to different folks. Sounds like you want a file transfer tool or one built into an editor?

I don’t know your work environment so I don’t really know what your asking. I’m just going to spit out some SWAG thoughts in the hopes it helps. I’m assuming by the use of the term IDE that you’re talking GUI.

IDE:

The traditional (included) Python IDE “IDLE” works reasonably well on small screens. I used it to do Python work on my PocketCHIP with a 480x272 dot screen. You’ll likely have to employ the [ALT]+drag trick to access all of some of the dialog windows. But on the DevTerm you should be able to run the interpreter and editor windows side-by-side, which could be nice.

Geany can be trimmed down to work well on a small screen as well. IDLE is the lighter of the two. But Geany provides a significant number of plugins for various situations, mostly related to interacting with compilers. Its been a while but Gedit could be trimmed down to work well on the pixel challenged displays. I gave up on it a while back since it took soooo long to start (ie heavier). Geany is much lighter!

Oh! And don’t forget NEdit. Very light! Very useful. I had trouble with it knowing when it receives focus. [ALT]+[TAB], type… nothing happens. Click away, click back, now it works. Its a shame really. But the annoyance of having to poke it to wake it up caused me to find Geany. :wink: I still keep hoping they’ll fix that one day. When I first got involved with NEdit, way back when, it worked wonderfully well. Anyhow, NEdit would work well on pixel challenged screens and I think that was the default IDE that came on my R-01.

SSH:

I’m guessing you’re trying to do away with a separate step to SSH files back and forth? I imagine some editors and so-called IDEs provide built in remote access to files. But I don’t use them. They’re not very UNIXy. In other words: their usefulness is limited to what the IDE is equipped to do. If you’re talking to proper SSH/SFTP servers I have had wonderful success with sshfs. This mounts a remote file system, through SSH, to your local file system. Then you can use any and all tools you have available on the content of that remote file system. This is very UNIXy.

If you setup SSH keys to do your authentication its trivially simple to wrap the mount, session application(s) (IDE, editors, …) and dismount commands in a script, which can then be packed into an icon (GUI launcher). I have one such script that launches and arranges an enitre HD sized desktop of tools to work on the remote system’s files all with the click of an icon. In this scenrio Zenity is very useful for graphically reporting issues.

1 Like

I am referring to, writing the script in an IDE, and then placing the file in the workflow via SSH. I already do the latter. I just want a way to do the former on the devterm and eliminate about 80% of my need to travel with a laptop.

I am referring to, writing the script in an IDE, and then placing the file in the workflow via SSH. I already do the latter. I just want a way to do the former on the devterm and eliminate about 80% of my need to travel with a laptop. No need for a step to eliminate SSH step lol. I’ll have to give the IDLE IDE a second look for sure. I appreciate the informative response!

You might also find Geany a useful alternative. It can launch a python file in a terminal window, with the push of [F5], or through the “miniscript” plugin. Its more refined as an editor and automatically understands Python. It also works with other languages. I often use it to test run PHP.

I always find that I have to bend my brain to fit IDLE. Nothing particularly wrong with it… it just does things very differently than I’m used to. :smiley:

I tried installing AstroVim but it blows up on my a06 on the default Armbian/ubuntu shipped with DevTerm.

It is complaining of lua not finding core.utils and not finding PackerSync, even after cloning the Packer repo. Neovim runs, and running basic lua commands in neovim work.

Am I missing something? Or is there something else needed as a base? Have you tried this on the DevTerm already?

IDLE is honestly awful.

Visual Studio Code run fairly well on a A06 and from memory it worked ok on the CM3, it is not dedicated python, nor necessarily the most lightweight, but from my own test it was not too bad.

Somebody in a different thread mentioned Spyder working on devterm: https://www.spyder-ide.org

I need to test it on my DT but CudaText has good performance overall

1 Like

Heard about this from NodeMCU community: https://thonny.org/
It has rpi builds.

If you’re into scientific computing with python, itom might be right for you.

I tried compiling it for the DevTerm, with no results so far thanks to the opencv dependency.
It should be possible tough, I’ll post instructions if it pans out.

1 Like

CudaText looks promising, get it working on the DT?

Yes and actually looks great, I use it at work on the PC so it will be a nice addition to the DevTerm.

You need to download:

Download CudaText from SourceForge.net for the Qt version

Or if you prefer Download CudaText from SourceForge.net for the GTK2 version

I used the Qt one, which also needs the libqtpas dependency sudo apt install libqt5pas1

1 Like