R-01 screen won't turn on again after shutdown

Hi I received my devterm r-01 today and built and turned on successfully. I ran update + upgrade to clean the install then rebooted and then I ran autoremove to clean the extra packages. After a few hours of playing around I ran

$ sudo shutdown -h now

Now when I’ve come back to it and tried to turn it on again, the green light comes on down the bottom and sporadically flashes once. I disassembled, checked and reseated everything, the ribbon cables, new batteries, as card, the core. No damage and everything looked good and connected securely. When I turned it back on again the same result, just the power button on down the bottom and black screen. When I tried on usb-c power the screen remained black but the fan also started whirring loudly. Anyone have any ideas? Is my screen toast?

1 Like

Same thing happened to me, I don’t think you can upgrade the kernel or the firmware without a patch or something, you need to reflash your sd card to get it working again

Yup, also having that issue. After a sudo apt update && sudo apt upgrade I get a few warnings in the process, but it will complete. However after I reboot there is no video. Had to re-flash the SD card. I’m not sure what the issue is, but like stated above, its probably a kernel issue that needs to be fixed.

Thanks to you both, turns out that was exactly the issue. Connecting the SD card to my PC and flashing it again with the downloaded image fixed it up right up

$ dd if=Devterm_R01.img of=/dev/sdX

Does that means if I run apt upgrade again it’s just gonna do the same thing?

1 Like

yea, running “apt upgrade (package name)” for a bunch of packages works though, even the ones that update the initramfs, which makes me think its a kernel issue. i think you could “apt-mark hold linux” and try a full upgrade, they will probably fix this i would imagine though…

Yeah just tried doing another full dist-upgrade and it gives me the same black screen when booting up. Is there any where to report this apart from this forum? Seems the shipped SD cards and downloadable image cannot be updated without breaking

I think the appropriate place would be: Issues · clockworkpi/DevTerm · GitHub, but I’m not sure how they do things…


Thanks a lot - that totally fixed the above issue I had as well. Can confirm it works.