R-01 / toot & exchange client

ok just bought a new device. picked up the R01 after having a few beers. praying to our Lord that it doesn’t take 12 months to ship.

I would like to level up my terminal skills. I am somewhat concerned though, as I am a little new to the Linux. would like to connect with my fediverse server that I run: my0.net. I think there is a terminal app called “TOOT”. but I use my yubi (nfc or usb) for webauthn. is this an issue with this device?

what is the best way to manage wifi networks?

how can I check my exchange e-mail from a command prompt?

I am sure this is covered elsewhere. But not sure where to check or if there was a guide already written. any help would be appreciated thank you so much.

1 Like
  1. webauthn is not directly supported by toot-cli. Besides, running a web browser is painful on R01. You might want to use TOTP or login on another device then transfer the credentials.
  2. You can manage your wifi though either network manager or wpa supplicant. Sometimes iwd works.
  3. I have no idea. I’m not aware of any satisfying CLI client.

You shouldn’t expect here to be any guide of this kind. Read the manual/wiki/discussion of corresponding software.

1 Like

What I use on my R01 is usually just bloat ( bloat - A web client for Mastadon Network , I have a version with a lot of changes at GitHub - pete/bloat: Mirror of a minimal set of changes to BloatFE / git.debu.gs Git - bloat/summary ). It runs fine on w3m or other super-minimal browsers. I use bloat from mothra: the R-01 runs drawterm ( http://drawterm.9front.org/ ) just fine, so I can connect to the Plan 9 machines.

There’s also sshocial ( Duponin / sshocial · GitLab ) which doesn’t require a browser, but I haven’t used it; the instance I’m on has an ssh interface built in.

I kind of wonder why CPi doesn’t run an instance. It’d be pretty cool to be able to get news there. (I locked my Twitter account and quit using it in 2018, but you can’t even use Nitter to read Twitter accounts any more.) On the other hand, every time I talk about the DevTerm or uConsole on fedi, people tell me it’s not a useful device and that it’s impossible to do work on it, even if I am talking about having worked on it all day.