Retroarch runs at a unbearable spead

Hi guys, my A04 deverm runs ok. But the retroarch is really slow.
I have the default one, which after some tinkering is playable. But the fps and sound are unbearable, it cant run gameboy game at full speed. The gba games runs at around 40 fps with broken sound.
Then I get the snap (which disabled my printer) one, after some tinkering, the bios is still missing (even I have manually copied the bios).
Is this common? I don’t think A04 is not capable to emulating those old games (even a psp runs that smoothly).
Any help?

I am experiencing the same on my A04.
Also switched from repo version to snap version to see if it’ll run smoother.
You can fix your printer by adding an apparmor rule (it’s what disables the printer).
However the problem I am having is, that the gamepad controls aren’t picked up in the snap RetroArch. They worked perfectly fine in the repo version.

Thermal printer service doesn’t start - DevTerm - clockworkpi

1 Like

Have you run the X11 performance improvement patch and a04 gearbox setting of ‘4’ to set all cores on and to maximum speed before running retroarch?

  • Perform a system update and a performance improvement patch:
    • sudo apt-add-repository ppa:aglasgall/devterm-a04-xorg && sudo apt update && sudo apt upgrade
  • Install gearbox:
    • sudo apt install -y devterm-kernel-current-cpi-a04 devterm-gearbox-a04 devterm-fan-daemon-cpi-a04
  • reboot
  • sudo devterm-a04-gearbox -s 4 # performance mode for A04. Run after every boot.
  • run retroarch
3 Likes

I have tried to fixed that, have you tried to update the profiles within the RetroArch?
Now my issue is ‘failed to open liberetro core’

BTW, I tried that printer’s code, still cant work.

So one thing that I was having issues with was running the games in full-screen mode vs. in a window. When running them in a window, I would get full speed and no issues with audio while emulating SNES. Have you run it in a window?