clockworkpi

-SOLVED- Lightbar keys suddenly stopped working with MGBA?

So yeah, I’m here to troubleshoot again.
I have no idea why or how it happened but for some reason the MGBA standalone emulator in the retrogames folder stopped recognizing the lightbar keys. i went to check with other emulators, where they seem to work fine, they also still click and light up as they should.

I have no clue as to how this happened or what caused it, but could it maybe be that it is because i played some gb and gbc games that didn’t have shoulderbuttons?

And is there maybe a way to fix this? Like a config file i could edit?

Thanks in advance guys btw, i don’t think i’ve ever shown my gratitude towards this helpful community

1 Like

Someone else had this same problem recently so you’re not alone.

The new os 0.5 has a newly configured Retroarch config. Mgba depends on Retroarch for bindings.

You will need to go into settings>input>port 1 binds.
From there, select “bind all” and input your keys as they come up, including the light bar keys.

The most likely culprit is the auto Retroarch editing script in the key layout option in the Gameshell settings. This updates the controls in Retroarch, but possibly doesn’t include the lightbar keys. The previous version may have been set up manually.

Hopefully this helps.

1 Like

javelinface, once again you swoop in and save my day.
As you instructed, I booted up Retroarch, went to the settings and did a quick rebind, then started up MGBA with a rom and behold, everything is back to normal.
Thank you, Sir!
And whatever it is you are doing right now, I hope you have a fantastic day, a helpful soul such as yourself deserves it.
Stay beautiful!

1 Like

Aww!! Thank you so much! It means so much to hear that. Helping one another is always good. Makes everyone feel better. You’ve really made my day. :slight_smile:

1 Like

I could not agree more with that and am glad that i could improve your day a little, as you have with mine before. :wink::+1:

1 Like