clockworkpi

Shoulder buttons stopped working in 0.5 [Solved]

Hi! I’ve recently updated to 0.5 and noticed that shoulder buttons stopped working. There’s no reaction in games and the lights beneath buttons don’t turn on when I press them. At first, I thought that I messed up connections while changing SD card, but then I noticed that while I press them on boot during “happy hacking” screen, they seem to register character inputs, so it seems like the problem is somewhere on software side. Any suggestions on how to enable them? Maybe there are some mapping settings that I missed after installing new OS?

Oh, sorry for duplicate question, I didn’t find this topic using search

1 Like

Don’t worry about it
Hope it works for you again

1 Like

yep, it works, thank you. the only thing that does not work is button lights, but it does not bother me at all

1 Like

Oh! That is another issue altogether! It should. Which means there is probably a problem with the pins.

It’s super strange that the lights just stopped working. I mean maybe a loose connection? But the fact the keys are still working. Did you ever flash a custom binary to the arduino controller?

1 Like

No, I didn’t touch Arduino yet. I probably messed up connections while I was installing new SD card. I’ll try to check everything this weekend. Are lights controlled directly by Arduino? Does it mean they should work any time the GS is powered on? It’s not something tied to OS, right?

1 Like

Unfortunately I dont have a light key to check the board, and also there is no schematic, but judging by the schematic of the conector https://github.com/clockworkpi/GameShellDocs/blob/master/clockwork_Keypad_Schematic.pdf

I would say yes, there are 7 pins, 2 for power (VCC,GND) and 5 for keys (one for each key)

So yeah, the leds are most likely powered by VCC or by the key pins.

I didn’t find any bent pins or anything suspicious in connectors. I’ve tried turning the cord other way round, and it didn’t help. The buttons do work, but there’s still no backlight. I think I’ll need to check continuity of the wire when I’ll have a chance. Is there any chance this is software related? I think I’ll also try booting from previous SD with 0.4 on it just to make sure.

my bad. I feel a little stupid, but there were bent pins on both sides (!) that I didn’t see at first. now backlight works just fine. thanks for help

1 Like

That is a relief! Which ones exactly? I’m more surprised you had two pins non functional yet you were still able to use the keys.

It was probably the same pin on both ends, that why it was working ok. It was the one on the side, probably rightmost, I didn’t really pay attention which exactly. I just straightened them with a sewing needle and everything works how it should now

BTW, I want to mark this topic as solved, but can’t seem to find the way to edit the topic name

Ha! Dang, you got lucky I guess. Potentially a good thing to know if you say, don’t want lights. It’s something that I never see, but when I’m playing it in bed, I fear flashing lights on my sleeping partner.

Btw, I’ve changed the title to say that the problem is solved. :slight_smile:

1 Like