clockworkpi

Solved: Shuts off after the "Loading" screen

I just got the Gameshell and tried unsuccessfully to install Retroarch. I ram riffed the folder, went through the entire process again, got up to running make -j4, and the Gameshell froze after a bunch of files compiled and my ssh session timed out. I had to manually remove the battery cord.

It reboot, then it goes to the Loading screen and then… black. Nothing works except removing the battery cable, but then it just loads and goes to a black screen again. Not sure how to solve this.

Hullo! Welcome to the forums.

Change the number of jobs down to -j3 or -j2

It just can’t keep up with doing so many jobs at once, despite having multiple cores. That’s just for compiling Retroarch. As for why it’s going black, if you can SSH into it, you should be able to recover with a git pull or similar.

Might be better off just starting from scratch. I’ve made an image with the latest Retroarch pre compiled if you just want to quickly test it out. Save a few hours of compiling time :wink:

Hope that works!

I had the same issues once with retroarch and a couple of things solved the freezes:

  1. I changed my charging cable to a better one that provided more amps and stopped freezing.
  2. I found a bug I had that there was a process running 100% I never found out why but I solved it just doing a git pull on the launcher.

And yea reducing the number of jobs is a good idea.

Yup, I ended up just going with an image with the updated Retroarch. Thanks for the help you two

1 Like