Some games I tested on my Uconsole

I received my Uconsole in december, just before the holidays. I must say that I had a blast playing some of my favorite games on it, so I though I would give a small feedback about the good, the bad and the ugly.

First, I must say that I have a 8Gb RAM CM4 and I overclock it with the following parameters :

  • over_voltage=2
  • arm_freq=1700

I have not tested other settings, that may be perfectly valid, but this was the most stable for me.

Except for Retroarch and ScummVM, I ran most games either through box86/box64 (Linux binaries) or box86/box64 + wine/wine64 (Windows binaries). To install these, I just followed instructions from the wiki (box64/docs/X64WINE.md at main · ptitSeb/box64 · GitHub).

Retroarch
Works nicely with the proper cores. I got mine from there : GitHub - christianhaitian/retroarch-cores
Only tried games up to PSX, I don’t think CM4 can handle more than that. Having only for real buttons can be a bummer for some games. I am thinking of designing and printing a proper joypad-shield-thingy, but I would also appreciate that someone much better at this manage to do it before me…

ScummVM
All the games I tried worked out of the box :slight_smile:

Fallout 2
As well as mods based on Fallout 2 engine: Fallout et tu, Fallout Resurrection, Fallout Nevada.
Works pretty well using box86 + wine. I used xrandr to fake 960x540 resolution, which makes text much more readable.
Played for several hours without issue. A bit heavy on the cpu, which makes the back of the uconsole a bit hot, but okay.

Diablo
Works perfectly with devilutionx, awesome :slight_smile:

Heroes of Might and Magic 3
Works perfectly with VCMI compiled from source.
Played one scenario of the main campaigns from start to end without issue.

Baldur’s Gate EE, Baldur’s Gate II EE & Icewind Dale EE
Both BG games Work out of the box with box86 + wine. For some reason Icewind Dale is a x86_64 PE, so it needs box64 + a 64 bit wine prefix.

Played Icewind Dale for 10+ hours with very good performance. Only got in the menus for both BG games, but I don’t see why they should not also work fine.

Installing mods like SCS is painfully slow and buggy through Wine on the Uconsole, but I managed to do it for BG2 on my computer and copy back the game to my Uconsole.

Dwarf Fortress
Copied the latest Linux version from the Steam directory on my laptop. Box64 should wrap everything up with native libSDL, but the latest version on Bullseye is quite old and some functions are missing, making the game crash at startup. I compiled SDL from source and had to override the library path with LB_LIBRARY_PATH to get it to launch properly.

As a sidenote, to anticipate on similar issues, I also compiled latest releases of SDL-ttf, SDL-image & SDL-mixer. So they might also be required to have DF running, I didn’t check :-p

Created a standard world in a reasonable amount of time (~5-10 min), embarked and the game runs relatively smoothly. However due to how the game can become quickly CPU-intensive, some settings adjustments might be needed in order to keep it that way. Still I got a pretty 10-15h of enjoyable playtime with a tiny world and intend to keep playing !

Cataclysm : Dark Days Ahead
Compiled experimental build from source. Everything works great, but I guess heavily dense maps (items + npc) will make the CPU cry a bit.

Armageddon Empires & Solium Inferum (original no the upcoming remake)
Both work with wine + box86. You need to scale with xrandr though, because fullscreen and windowed are hardcoded to 1024x768. However the games run very slowly, probably because their game engine is Adobe Director… Bummer though, because I would really like playing them in the couch.

Dominions 5
There is an arm 32-bit executable in the folder when installed on my laptop through Steam, after installing armhf package for SDL and SDL-ttf it runs but some fonts are unreadable.
I had better luck running the amd64 binaary through box64, quite slow to create worlds, but ok once in game. Did no try battles though.

Steam
Well, it kinda works with Box64 and Wine (there is a pseudo-official guide on Box64 wiki). But it’s horribly, painfully slow. At some point I just stopped trying to use it. However, if you have Steam installed on a x64 computer, some games do not mind if you just copy games and launch them with box64/wine. You just have to try :slight_smile:

FTL
Copied from my Linux steam directory, works great.

Songs of Syx
After many attempts, I managed to get it right and launch a game, but the Uconsole runs it very very slow. Well, unplayable-slow actually :-/

Remnants of the Precursors
Picked the jar file and ran it with native arm jre, works great.

Jagged Alliance 2
Compiled ja2-stracciatella on the uconsole and the game runs great. Choose an appropriate resolution (I went for 1066x600) if you don’t want your eyes to bleed.

OpenXCom
Compiled on the Uconsole, seems to work nicely, but did really played it (just launched a game and quit).

Simcity 3000
Works in box86/wine without issue.

4 Likes

I am running with arm_freq=2000, over_voltage=6 and gpu_freq=750, works stable even with continuous loads. But it does eat the battery.

2 Likes

Heroes 2 and 3 are two of the first games I wanted to get running on mine once I get it.

Two questions:

  1. Can you give us more detail on how you got Dwarf Fortress running?

  2. Does FTL work with sound for you? I can get it to launch but without music or sound effects.

While Steam’s interface is slow as molasses, it’s great once you get it running in Small Mode. I am able to play the Steam versions of Into the Breach, Dungeons of Dredmor and ToME (with shader effects turned off, to prevent crashing) without issue on the 4GB CM4.

Hey, could you please tell me more about how to bring up HoMM3 on RPi?

  1. I compiled SDL, SDL-ttf, SDL-image & SDL-mixer from sources (see SDL2/Installation - SDL Wiki for SDL, similar documentation exists for other libs). Just take care to specify a custom prefix, like --prefix=/opt/newsdl when launching the configure script so make install will put them there instead of overwriting the ones installed from apt.
    Then launch dwarf fortress in command line, prepending your prefix in LB_LIBRARY_PATH (i.e. LB_LIBRARY_PATH=/opt/newsdl/lib). I use a very simple shell script that cd in dwarf fortress directory and does just that.
    I do not have my Uconsole with me right now, so this is from memory, but you should get the idea.

  2. I must get back to you on this since I do not have my Uconsole with me, but I am almost 100% sure that sound works. Maybe because I used my newly compiled SDL-audio lib ? I don’t remember if FTL uses this lib for sound… Well, if this is not the reason, I don’t remember doing something special to get it working.

Good find with Steam Small Mode, I did not know it was a thing :slight_smile:

You may be able to launch the Windows version with box86/box64 and wine, but I went with VCMI, which is an open-source re-implementation of the engine.

I just followed the pretty straightforward instructions from VMCI wiki : Installation on Linux - VCMI Project Wiki & How to build VCMI (Linux) - VCMI Project Wiki.

You will still need to copy Heroes 3 data from a legitimate copy to play the game.

2 Likes