clockworkpi

Stuck in command line

Hi

Just put my game gameshell together today, had a fiddle around… and accidentally got stuck in command line. I see the CPI screen, “happy hacking” and the prompt.

I’ve rebooted via the power button, and via ssh, but there’s still no UI.

What can I do? Is there a shortcut button I can use when booting?

don’t know why

but maybe re-flash the sd card will fix your issue

That seems a bit destructive. I’ve literally done nothing but setup wi-fi and play games; nothing added, nothing removed.

Doesn’t install confidence for reliability if things can go wrong so easily.

well
if you have connected wifi on GameShell
then you can ssh into your gs ,and fix it
find the GameShell ip in router’s admin page

so do you know anything about ssh , or linux?

A bit, but not sure if it’s enough.

I’m already connected via SSH. I assumed the load.sh script was enough, but that returns an error, “pygame.error: Unable to open a console terminal” so it seems that’s not the answer.

what is the results of command below on your machine?

 tail -n 30 ~/.bashrc 

#alias la=‘ls -A’
#alias l=‘ls -CF’

Alias definitions.

You may want to put all your additions into a separate file like

~/.bash_aliases, instead of adding them here directly.

See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
. ~/.bash_aliases
fi

enable programmable completion features (you don’t need to enable

this, if it’s already enabled in /etc/bash.bashrc and /etc/profile

sources /etc/bash.bashrc).

if ! shopt -oq posix; then
if [ -f /usr/share/bash-completion/bash_completion ]; then
. /usr/share/bash-completion/bash_completion
elif [ -f /etc/bash_completion ]; then
. /etc/bash_completion
fi
fi

if [ -f /tmp/autologin ]
then
rm -f /tmp/autologin
mpd ~/.mpd.conf
startx /home/cpi/launchergo/.xinitrc – -nocursor > /tmp/x.log 2>&1
fi
alias iujk=startx

got you problem

I guess you did an update in launcher

there is a bug between versions updating…

if you don’t know how to edit text under ssh use vim ,let me know

here is the whole file of ~/.bashrc

https://pastebin.com/eJRPg93A

if you changed ~/.bashrc successfully

just sudo reboot

Thanks so much for that – used nano rather than vim, otherwise all good.

Which is a relief, as downloading the image is ultra slow right now. Thanks again!

wait a while
new image will be released soon