clockworkpi

Gameshell won't get past this screen (solved)

This started after i got an error trying to install this https://github.com/samdze/godot-launcherhttps://github.com/samdze/godot-launcher
i’m scared if i accidently killed my gameshell as i can’t ssh into it anymore

What kind of error did you get trying to install the launcher?

Were you able to ssh into the GameShell before the error?
You should be able to login even though no launcher is able to run in that case. (wi-fi is enabled and auto-connects anyway)

When the GameShell is stuck in that screen it usually means the launcher is failing to be executed. There should be no risk of the device being dead.

i can’t exactly remember the error but i do remember it being something about files
i was able to ssh into my gameshell before the error
pretty quick update: i am able to ssh into my gameshell

Maybe, waiting a bit for the GameShell to auto-connect to Wi-Fi, you will be able to ssh again.

The file that the installation procedure modify is /home/cpi/.bashrc
To come back to the previous launcher you just have to change the occurrences of the string “godot-launcher” to just “launcher”.

There are two near the end of the file:

if [ -f ~/launcher/.cpirc ]; then
   . ~/launcher/.cpirc
fi

that ended up working, thanks for the help

1 Like

Just to be sure, which version of the GameShell do you have? The 512MB or 1GB of ram version?

The new launcher you tried to install has issues with the lima driver on the 512MB version.
Apart from that I’m also curious what error it gave you previously trying to install it.

i have the 1gb version

i just tried to install it again and the error looks like this

Mhh very weird, there seems to be no error but this error popup is shown nevertheless.
How are you executing the command? I use powershell (or cmd.exe) to connect via ssh and I type commands there.
This kind of popups can’t appear this way.

I’m using WinSCP, mainly because its easier for me to use, it has a built in CMD window

It may have some issues cloning the repository because some files have properties and attributes a Windows OS can’t read (e.g. executable bits), so they may be cloned incorrectly to the GameShell then.

I suggest trying to install the launcher via powershell or cmd.exe directly.

I’ll try that next time, thanks for the advice

1 Like