[UConsole]Fix Login Screen(sddm) Rotation after boot

After you set kde-plasma as your main DE do the next:

  1. add next line

xrandr --output DSI-1 --rotate right

to the file

/usr/share/sddm/scripts/Xsetup

  1. Add next lines
[X11]
DisplayCommand=/usr/share/sddm/scripts/Xsetup

to the file

/var/lib/sddm/state.conf

reboot.

after i got correct rotation right after boot. maybe it will help

To solve the orientation of KDE at startup, I use another solution: I boot directly on the desktop, then a script immediately locks the screen, which is always oriented correctly, even on an external screen! And I can connect normally.

and does it keep rotated after reboot? because when you set it via desktop it works, of course, but resets after reboot

Yes it is! This setting remains after reboot, because it’s a Desktop Environment’s setting, not a SDDM or Lightdm tweak.

(Sorry for English, I reply fast but trashy :sweat_smile:)