Unable to download anything even with a WiFi connection

wifi

#1

I’ve flashed version v.3 of the OS. I’m able to connect to WiFi, but no thing can be downloaded. For example, when I pull up Retroarch and try to download a core, it says “Task failed: downloading index.” When I pull up mGBA and try to run a rom, it says “Do you want to setup this game engine automatically?” and then the download never starts, it just hangs at 0.00Mb. When I pull up the settings for Gameshell itself and go to “Update,” It says “Checking update failed.” Any ideas :\ ?


#2

Could you try a ping 8.8.8.8 or something? Checking, if you can reach anything outside your own network.

Do you have SSH access?

I experienced a similar problem and changed the nameserver in /etc/resolve.conv to googles public DNS Server (8.8.8.8).


#3

You’re on the right track. I’m only able to SSH into it when it’s connected via ethernet. When I SSH in, this is what resolve.conf contained:

domain attlocal.net
search attlocal.net
nameserver 192.168.10.1

I changed nameserver to 8.8.8.8 and tried downloading things. It worked! As soon as I disconnected ethernet, however, I could no longer SSH into the unit or download things. Upon reconnecting and viewing resolve.conf once more, it had returned to 192.168.10.1. What do you make of it?


#4

Okay, well it seems your GS can’t resolve any names/domains to IP via your router. This happens to me, if I use my VPN-connected Router to get my GS online.

In Short:
A nameserver translates domains like something.com into an IP address like 123.123.123. There is more to know about that - much more - but take this at first.

On a personal computer I would dig deeper into the problem that causes this issue (maybe router-wise) but since the GS is a game console I’d go with a simple solution:

Set the Google DNS Server as default.

How to achieve that?

Well, before I write down the solution that I would attempt, I’d like to write down something you could smash into a search-engine and find out the solution on your own. Since we know, that we want to define a name server while using the resolve.conf / resolvconf (program), a simple query would look like:

“set dns server resolvconf”

If we know what context we are in, there is no shame to hack that into google and look what others say about it. Maybe someone tells us, to look another way - maybe we got things right.

This is part of the learning curve and solving things on your own. It may be hard but nothing is more rewarding than getting things to work.

My (untested now tested) approach to the solution:
Since resolvconf resets the content of resolv.conf we have to dig into the workflow of these components.
EDIT: Well, the resolv.conf file changes but resolvconf isn’t installed. Maybe some clockwork guys can shed some light on the underlying process.
I was too lazy to dig into the system and just installed via sudo apt-get install resolvconf.

Turns out, we can use some files to save our most and least favorite nameservers for resolvconf to put them into the file resolve.conf every time it gets rewritten. So I’d try to set my name server (e.g. 8.8.8.8) into a file that is located here: /etc/resolvconf/resolv.conf.d/tail

Please share the result. Maybe I went wrong somewhere.

Someone may be able to determine ‘the real problem’ but im fine with that for now. :wink:


#5

我和你一样遇到了这个问题。

不知道有没有办法可以手动安装引擎?