Unable to get past Welcome to clockworkPi screen


#1

I’m able to launch my gameshell but I can’t get past the Welcome to clockworkPi screen. I’ve tried launching multiple times and just waiting on the screen but it just goes to black screen. Additionally, if I press any buttons then I enter characters like “j”, “j”, “u”, “i”, “^[[A’”…

Has anyone experienced this issue? Does any know of a solution?

Apologies if this has already been posted but I couldn’t seem to find the solution in the forums.

Thanks.


#2

it seems the X of gameshell could not be started

try ssh into GameShell
and run

cat /tmp/x.log

to see what’s going on

and maybe provide the os version of your gameshell
like v0.1,v0.2, v0.3


#3

@guu Below is what was returned from that command when I connected to the gameshell via usb on my Windows machine and did ssh.

cpi@clockworkpi:~$ cat /tmp/x.log
xauth: timeout in locking authority file /home/cpi/.Xauthority
xauth: timeout in locking authority file /home/cpi/.Xauthority

X.Org X Server 1.19.2
Release Date: 2017-03-02
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.9.0-8-armmp-lpae armv7l Debian
Current Operating System: Linux clockworkpi 4.14.2-clockworkpi-cpi3-g638f2a7 #1 SMP Mon Dec 10 07:46:56 UTC 2018 armv7l
Kernel command line: console=ttyS0,115200n8 earlyprintk no_console_suspend root=/dev/mmcblk0p2 rootfstype=ext4 rootwait init=/sbin/init noinitrd panic=10
Build Date: 03 November 2018 05:53:43AM
xorg-server 2:1.19.2-1+deb9u5 (https://www.debian.org/support)
Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/home/cpi/.local/share/xorg/Xorg.0.log”, Time: Tue Dec 18 12:59:14 2018
(==) Using config file: “/etc/xorg.conf”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
modprobe: ERROR: …/libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file ‘/lib/modules/4.14.2-clockworkpi-cpi3-g638f2a7/modules.dep.bin’
modprobe: FATAL: Module g2d_23 not found in directory /lib/modules/4.14.2-clockworkpi-cpi3-g638f2a7
Invalid MIT-MAGIC-COOKIE-1 key
waiting for X server to begin accepting connections .
Invalid MIT-MAGIC-COOKIE-1 key…
Invalid MIT-MAGIC-COOKIE-1 key…
Invalid MIT-MAGIC-COOKIE-1 key…
Invalid MIT-MAGIC-COOKIE-1 key…
Invalid MIT-MAGIC-COOKIE-1 key…
Invalid MIT-MAGIC-COOKIE-1 key…
Invalid MIT-MAGIC-COOKIE-1 key…
Invalid MIT-MAGIC-COOKIE-1 key…cpi@clockworkpi:~$


#4

what is the version of your os image?


#5

According to another forum post, gameshell devices that were recently shipped are OS version 0.23. I just received mine on Monday from the pre-order in December '18. @guu should I try reflashing the OS as I’ve seen suggested? I only see v0.21 as the latest stable release to use.


#6

true
v0.21 is stable
because the latest image v0.3 use opensource GPU driver Lima
which is not yet stable
but you can Give it a try, it would be fun
:slight_smile:


#7

I have reflashed the sd card with v0.21 that came with the Gameshell. All is well now and I’m able to successfully start up to the menu. Thanks @guu for the support.