Error after Updating via Settings

Hi, I am stuck. I updated my Gameshell through the Update option from the Settings menu. Now, it won’t boot. I forced shut down it and turned it back on; the logo appeared, it went black screen, and the the Booting message appeared but endlessly.

I have modified it to USB ETH. I can SSH to it, but don’t know how to fix it.

Please help!

Thanks in advence

what is your os version?

I am not sure as I cannot go into the launcher. But it is the version we got from the January 2019 shipment.

so go into ssh

ls /home/cpi

paste the results

Maybe resetting all the files from the launcher to the newest update could solve your problem in case some files are corrupted or more updated than others.

You could try this on ssh:

$ cd /home/cpi/launcher 
$ ./update c4587c1

Lastly you could also try to flash a clean ClockworkOS image in your microSD card and try again.

./ c4587c1

but is recently added
if the launcher is old

cd /home/cpi/launcher/
git pull


He could also do the whole procedure if he doesn’t have that specific file, just to be sure:

cd /home/cpi/launcher 
git pull
git reset --hard c4587c1
git submodule init
git submodule update
1 Like

Hi guu & doodom,

Thanks for the help. I tried all the step above, but when I ./ i got this error message:

Traceback (most recent call last):
File “”, line 52, in
pygame.error: Unable to open a console terminal

I think that error means that you have not any XServer running or that the system cannot find it.

Could you please run

export DISPLAY=:0



and tell us what happens?

Do you have the .xorg.conf and .xorg_lima.conf files in /home/cpi?

Hi doodom,

I run export DISPLAY=:0 before ./ and got this (pardon my lengthy message):

org.freedesktop.DBus.Error.TimedOut: Failed to activate service ‘org.bluez’: timed out
Charging 2
(‘CheckBluetooth:no bluetooth’, (0, ‘’))
wifi is connected
[‘’, ‘slowpoke’, ‘32’, ‘0’, ‘28.8 Mb/s’]
Traceback (most recent call last):
File “”, line 600, in
File “”, line 509, in big_loop
File “/home/cpi/launcher/”, line 463, in ReadTheDirIntoPages
self.ReadTheDirIntoPages(_dir+"/"+i, pglevel+1 ,self._Pages[ len(self._Pages) -1])
File “/home/cpi/launcher/”, line 494, in ReadTheDirIntoPages
File “…/Menu/GameShell/10_Settings/”, line 20, in Init
File “…/Menu/GameShell/10_Settings/”, line 13, in InitListPage
File “…/Menu/GameShell/10_Settings/”, line 97, in Init
File “/home/cpi/launcher/Menu/GameShell/10_Settings/Bluetooth/”, line 812, in Init
File “/home/cpi/launcher/Menu/GameShell/10_Settings/Bluetooth/”, line 802, in Init
File “/home/cpi/launcher/Menu/GameShell/10_Settings/Bluetooth/”, line 766, in RegisterMyAgent
obj = bus.get_object(BUS_NAME, “/org/bluez”);
File “/usr/lib/python2.7/dist-packages/dbus/”, line 241, in get_object
File “/usr/lib/python2.7/dist-packages/dbus/”, line 248, in init
self._named_service = conn.activate_name_owner(bus_name)
File “/usr/lib/python2.7/dist-packages/dbus/”, line 180, in activate_name_owner
File “/usr/lib/python2.7/dist-packages/dbus/”, line 278, in start_service_by_name
‘su’, (bus_name, flags)))
File “/usr/lib/python2.7/dist-packages/dbus/”, line 651, in call_blocking
message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

And i cannot see .xorg.conf and/or .xorg_lima.conf in /home/cpi

Well, that’s a really weird error. Maybe a developer from Clockwork Pi could shed more light at this problem right now, but I think it’s somehow related to DBus or the bluetooth daemon.

You could simply flash the latest Clockwork OS image in your microSD. Just be sure to backup up every game and save data you have using WinSCP or any other SFTP client to that ease that proccess.

And those .xorg.conf files should be inside /home/cpi/launcher. Sorry, my bad for indicating you the wrong path. Use:

ls -la /home/cpi/launcher

to list all the files inside that folder including the hidden files (the ones starting with a dot in its name).

You could even try to run the other launcher from ssh and tell us what happens:

cd /home/cpi/launchergo
export DISPLAY:=0

It could work since that launcher is based on Go instead of Python although I wouldn’t hold my breath for that.

the problem is your gs has no Bluetooth working on

your os image is v0.1 for sure

try to upgrade you os image

v0.21 would be ok

1 Like

Hi guys, sorry for my late reply, and thank you very much for all you help! I finally updated my image to version 0.3, its working fine now. Thanks!