Update to 0.3 instructions?

I was thinking that by going to the launcher under the settings menu, the update will auto update to 0.3 via wifi. Apparently it is not the case, so how do you flash the new update? SSH? or copy directly into SD card?


Is it worth upgrading to 0.3 yet ?

So far, the reports on this forum suggest that it is stable, though the Mali GPU option is still buggy, but i can live with that.

I am more interested in testing new cores for retroarch, 0.2 isn’t much at the moment.

I am still in 0.2 - my RetroArch is mainly for early emulation (think SNES and earlier) whilst on the train to / from the office

I think GPU is overkill for me and I am happy as it is for now - once Mali is rock solid I might upgrade. But no rush.

I have the same question. How do I upgrade to OS v0.3? And how do I know which OS version I’m currently at?

Flashing the TF-card is the only way to upgrade os image right now

launcher only updates itself

Thank you. I just got this unit last week. Was it loaded with the latest OS image? How do I check the OS version? I tried to search in the forum. Many people asked the same question but I couldn’t an answer.

maybe you can paste the uname -a from gameshell to here

$ uname -a
Linux clockworkpi 4.14.2-clockworkpi-cpi3-g638f2a7 #1 SMP Mon Dec 10 07:46:56 UTC 2018 armv7l GNU/Linux

Someone mentioned that v0.3 has 4.20 kernel. But in clockworkOS v0.3 with GPU driver is available!, the about page shows the kernel is of v 4.14 in the video.

yeah ,it’s hard to tell which os image you are using now
I guess it is v0.2 or v0.21

what is the output of

dmesg | grep lima


It has some lines with lima. Does Lima only come with v0.3 image?

$ dmesg | grep lima
[    0.885066] lima 1c40000.gpu: bus rate = 200000000
[    0.889875] lima 1c40000.gpu: mod rate = 384000000
[    0.895040] lima 1c40000.gpu: gp - mali400 version major 1 minor 1
[    0.901276] lima 1c40000.gpu: pp0 - mali400 version major 1 minor 1
[    0.907579] lima 1c40000.gpu: pp1 - mali400 version major 1 minor 1
[    0.913883] lima 1c40000.gpu: l2 cache 64K, 4-way, 64byte cache line, 64bit external bus
[    0.922437] [drm] Initialized lima 1.0.0 20170325 for 1c40000.gpu on minor 0

ok, pretty sure you os image is not v0.1 :joy:

and according to the time you got gs

It’s probably v0.3

At present, I can only guess. I think that there will be a clear record of os-image version number in the following version.

I see. I will still try to flash the TF card with the 0.3 image, because I have exactly the same issue as this post Retroarch CPU very high. @Long_Nguyen said the high CPU issue was resolved after upgrade the OS version. I’ll give that a try.

Showing the OS version in the about page would be a good idea.

yeah indeed,if you flashed the v0.3 image ,choose lima in launcher

then it can reduce the CPU usage, but lima is not solid stable now, so be carefully and good luck

After upgrade to v0.3, the Kernel’s version does change. uname -a gave me Linux clockworkpi 4.20.0-clockworkpi-cpi3-00001-ga2b7682c5366 #2 SMP Wed Jan 2 05:56:21 UTC 2019 armv7l GNU/Linux. Retroarch also doesn’t take 300% CPU even only when the menu is shown.

I just tried doing the software update, and my screen has been stuck in “Uploading” for the past 20 minutes. How can I fix this? It’s not moving from this screen.