GameShell OS Image v0.6 gamma

New GameShell OS Image
v0.6 gamma

Armbian jammy (ubuntu jammy) based 2210 LTS support comes with an almost perfect open source GPU Lima driver.
Completely replaces the original launcher with LauncherGo to improve performance and reduce power usage.
Updated RetroArch to v1.14.0
Updated Love2D v11.0 Mysterious Mysteries
Integrated ClockworkPi APT repo


It’s been a while since a gameshell OS image. Nice to see an armbian rebase, kernel update, and launchergo finally in place. I will try it out!

1 Like

Thank you for the new image, installed it and tried a few emulators without a problem. But I can’t get pico8 working.

1 Like

It appears there’s a lot missing in launchergo, and the old launcher relies on python2 and wicd, neither of which are fully supported in the current software. PICO-8 isn’t present, GPSP doesn’t appear to work, and MGBA is very slow. Overall though it’s neat to be on armbian and really modern software.

Thanks for the feedback, will update those missing in next release

1 Like

what rom ? I’ve tested the MGBA on my side, it looks normal , I ran the super mario game

I am happy to test. I tried 2 GBA games, Fire Emblem and Kirby & The Amazing Mirror. Both have choppy audio and are in slow-motion. My previous OS image is the community image from here: Custom D.E.O.T. V2.0+/Clockwork OS v0.5 image - With customised DEOT interface, Kernel 5.7, Optional 1400MHz OC, Debian 10 Buster, Retroarch 1.9.0, Mupen64+ plus more! (Current build: 200903)

The configuration from that image seems to work a lot better. I have the beta image on a spare SD card so I can try anything you want.

1 Like

I wanted to try it out, but I get this horrible stuttering and tearing of the screen. Any idea what causes it?
Also using B to confirm and A to go back is weird, and switching layout in settings doesn’t change it (I guess it’s launcher go thing)

btw, if this helps, I think I had the same problem when I was trying DEOT build, but I didn’t bother then, and just switched back to regular os

1 Like

Is it just the launcher interface tearing or everything tearing?

I mean , if you ran some program, like retroarch

I didn’t check retroarch, I can check it a little later. But it was starting tearing right from the beginning of the boot, so even command line “happy hacking” part was affected, so I guess it’s not just launcher

1 Like

OK, got you

I will fix this issue in the next 0.6 os Image

thanks for your important feedback


os image updated

kernel restored to avoid tearing problem

and added Music Player , Pico8 in launchergo


just checked. now it works great, thanks. gonna try some games during the weekend

New user GS user here. Thank you some much for the updated image, that’s really appreciated !

Is the lima driver disabled by default ? If so, how can I switch it on ? My GLES application reports
Renderer: llvmpipe (LLVM 15.0.6, 128 bits), Shading language: GLSL ES 3.20
which looks like a software driver.

Sorry for the mistake

Lima is enabled by default, and dont need to switch back to fbdev, lima is stable enough now

But I forgot to add cpi user to render group in image,

that is why X can not use lima driver


ssh into GS


sudo usermod -a -G render cpi
sudo reboot

then you will have lima


just re-download the image, clockworkos_v0.6_gamma_2.img.7z

1 Like

Yes I ran the two commands and the gfx driver switched automatically to lima, thank you! :smile:

Now I face the issue that initializing the driver (or creating a rendering context ?) takes a lot of time: if I run
time DISPLAY=:0 glxinfo,
I get the relevant lines:

Vendor: lima (0x13b5)
    Device: Mali400 (0xffffffff)
    Version: 22.0.5
    Accelerated: yes
    Video memory: 0MB
    Unified memory: yes
    Preferred profile: compat (0x2)
    Max core profile version: 0.0
    Max compat profile version: 2.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 2.0

OpenGL ES profile version string: OpenGL ES 2.0 Mesa 22.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16

so yay!
but the command itself took

real    0m30.443s
user    0m0.315s
sys     0m0.150s
1 Like

Glad to know

You pointed out a problem encountered in reality, that kernel 5.3.6 is relatively slow when starting binary programs, running is ok,but if a newer kernel is used, there is a chance of causing screen flicker, and crashes, so until this problem is solved, I can only use kernel 5.3.6 for os image
The known shortcoming currently encountered is that glmark2 cannot run normally and will crash, but everything else is still okay for now


All of my RetroArch cores was running without savestates. It looks like core info files was not downloaded successfully, and also the cores did not show in the list. Does anyone had the same issue?

I think issue was with action.config files. They are pointing to /home/cpi/apps/emulators/ folder. There was no core info files in that folder.
I think it can be fixed by go to RetroArch and change core info download folder to /home/cpi/apps/emulators, then download them again

1 Like