clockworkpi

[USB-ETH] How to transfer files if you have unstable wifi

Which launcher version do you have?

It says stable 1.21

I just upgraded to the new ClockworkPiOS version 2.1. While USB-ETH is preconfigured, it is configured to act as a DHCP Server. If you wish your computer to act as the server to share the Internet to the GameShell, you’ll need to make a few changes. The easiest solution is to rename the files:

     /etc/default/isc-dhcp-server  to  /etc/default/isc-dhcp-server.bak
     /etc/dhcp/dhcpd.conf          to  /etc/dhcp/dhcpd.conf.bak

then edit /etc/network/interfaces to change the network configuration. I left it static to assure that the IP address remains the same. This is the configuration to share the Internet from a Mac:

     iface usb0 inet static
             address 192.168.2.2
             netmask 255.255.255.0
             gateway 192.168.2.1
             dns-nameservers 192.168.2.1

Unfortunately, the changes to the TinyCloud app in Launcher doesn’t check the address of USB-ETH, but displays a static string set in the python app itself! Rather than fixing the issue, I chose to simply replace the string in the app located at ~/launcher/Menu/GameShell/98_TinyCloud/__init__.py, replacing the line:

              [ "usb-eth-addr" , "192.168.10.1" , self._ListFontObj, self._URLColor]]

with:

              [ "usb-eth-addr" , "192.168.2.2" , self._ListFontObj, self._URLColor]]

Restart your GameShell and you’re back in business!

1 Like

I’ve install HoRNDIS on mac, but the clockworkpi still can’t connect to the network through the settings on the clockworkpi, weirdly. anybody help?

Hey all just wanted to say that on my Kubuntu 18.10 install, it all just worked! All I had to do was plug in a USB table and attach my clockwork pi and everything happened automatically!

谢谢您的答复。

请问能不能详细说明一下osx系统下如何用usb链接game shell?
我按照你的办法做了,但后续要干什么我还不清楚。
谢谢!

Thank you for your reply.

Can you elaborate on how to use the usb link game shell under the osx system? I did it according to your method, but I still don’t know what to do next. Thank you!

If you followed the above setup, and installed HoRNDIS on your Mac, your next steps would be accomplished in your System Preferences on your Mac. Go to the Sharing Preferences, and select Internet Sharing (Don’t turn it on yet!). Set Share your connection from to Wi-Fi or Ethernet, depending on which your computer is using for your network. Then check RNDIS/Ethernet Gadget in the lower box. Now turn it on with the checkmark and confirm by clicking the Start button.

Now go to the Network Preferences. Select the RNDIS settings. Configure IPv4 as Manually, IP Address: 192.168.2.10, Subnet Mask: 255.255.255.0, Router: 192.168.2.1 and then click Apply.

Now when you connect your GameShell to your Mac, it will have full access to the Internet through your computer. You should be able to SSH to your GameShell with the command:

ssh cpi@192.168.2.2
3 Likes

WX20190222-141130%402x

f非常感谢您的指导,按照您的说法我解决了链接问题,谢谢你!比心:)

ps.还想问问,是不是我用这样的方式链接GS之后,是不是电脑就没办法链接互联网了?

Thank you very much for your guidance. I solved the link problem according to your statement. Thank you! Contrast :slight_smile:

ps. Also want to ask, is it that I use this way to link GS, is there a way to link the Internet?

1 Like

抱歉又要打扰你了,我真的是对这个一窍不通。

目前我已经可以通过usb链接GS了,但是我以为这跟Windows一样,可以把GS当作一个存储来拷贝游戏跟文件。

我该如何在osx下,通过USB传输游戏?谢谢,不知道我描述的是否清楚。

Sorry to bother you again, I really don’t know anything about this.

Currently I can link GS via usb, but I thought this is the same as Windows, you can use GS as a storage to copy games and files.

How do I transfer games via USB under osx? Thank you, I don’t know if I described it clearly.

If you setup Internet Sharing to the RNDIS then your GameShell has access to the Internet. To transfer files, all you need to do is select clockworkpi in the Shared list in Finder. It will request User Name & Password; Enter cpi for both. This will give you access to both the games and music folders.

33%20AM

1 Like

每一步我都确实按照您说的操作,但是finder里面却看不到clockworkpi。。。我之前也疑惑了很久。。。

我再检查一遍到底是哪里有问题。

谢谢您!

Every step I did follow the instructions you said, but the finder does not see clockworkpi. . .

I will check again and there is a problem.

Thank you!

Does the Network Preferences show a connection for RNDIS? If so, go back to Finder and select Connect to Server… under the Go menu.
14%20AM
In the resulting window, enter smb://cpi@192.168.2.2 and hit Return
08%20AM
If the GameShell is connected, you will then be asked to enter a password. Enter the password “cpi”. Be sure to check the box, Remember this password in my keychain so you won’t have to deal with this dialog in the future…
39%20AM
If instead, you are presented with a dialog indicating There was a problem connecting… then there is something not configured correctly. Go over every step one more time.

1 Like

Hi @lasvegas, I am having some trouble getting this to work on my Mac. Could you perhaps share some screenshots of the system sestting you used ?

UPDATE: Figured it out and it works :slight_smile:

Hello guys!
I replaced kernel on my clockwork and now it does not work.:grinning:
I see this image


and that’s all

ssh into gs
run

cat /tmp/x.log

and what is your os image version?

I’m using windows 10 and image for clockwork from https://github.com/clockworkpi/Kernel

So ,i inserted sd card into my pc and simpy replaced image.
I have connection with clockwork via PuTTY.

This image works https://github.com/clockworkpi/Kernel/tree/master/CPI3_linux_4.20

use the kernel from v0.4

I shall update the post, it is a bit outdated, the information on it is perfectly fine but most steps aren´t needed in the newer OS. Right @guu?

I should add that it is already in the new os and you can change your gateway from wifi to usb eth cable from the launcher settings.

2 Likes

For some reasons, these settings don’t work for my Mac. I follow @mother3 settings:
Configure IPv4 as Manually , IP Address: 192.168.10.2 , Subnet Mask: 255.255.255.0 , Router: 192.168.10.1 and then click Apply .

And then ssh cpi@192.168.10.1

To connect to Internet while using USB-Ethernet, you need to put “Wi-Fi” on top of “RNDIS” in the Network setting.

1 Like