[USB-ETH] How to transfer files if you have unstable wifi

usb
macos
howto
windows
wifi
#21

I may just be missing something but I have done the configuration to a tee, but I can’t see the USB device in my device manager. Any thoughts?

#22

Yes, by ‘host’ I am referring to the computer the GS is connected to.

  • usb0: The interface of the GameShell as shown on the GameShell.
  • enp3s0f0u5: The interface of the GameShell as shown on my host.
  • enp10s0: The interface of the host’s network card as shown on my host.

The interface enp3s0f0u5 gets ip 192.168.10.1 using the original method, so I can SSH from host to GameShell which means the driver is working!

Now I want to try your:

The interface enp3s0f0u5 does NOT get an ip from my host using isc-dhcp-client with your configuration on the GameShell, whatever I try:

No problem assigning a static or dynamic address to enp10s0 though…

#23

I’m guessing that your host computer is running Windows. If that’s so, you need to go to your Network Connections control panel and right click on your Internet connection, be it WiFi or Ethernet, to select “Properties…” From there select the Sharing tab and check the Allow other network users to connect through this computer’s Internet connection option. Next, from the Home networking connection drop-down menu select the RNDIS adapter. This should set your host to supply the connection to your GameShell.

#24

My host is running GNU/Linux, like my GameShell. :wink:

#25

You’ll have to install an RNDIS driver for Linux. You’ll also need figure out how to share your WiFi with the USB/Ethernet connection.

#26

I’m unable to see a Drop Down that indicates RNDIS… I’m going to do some research :slight_smile:

#27

This is for Ubuntu, but might give you enough information. If the system sees a network to the GameShell, it should show up, by whatever name…

#28

Thx @lasvegas! I got it working! You put me on the right track.

  • I installed NetworkManager (because I was using netctl).
  • I followed the Arch documentation for sharing internet.

Now I have to work out the nerdy details (use static ip and netctl instead).

But I am happy the GameShell now has internet without Wi-Fi!

1 Like
#29

I have a Windows machine and want to share my host’s network/internet to my GS so I have followed the steps above. However, it seems the new uImage is causing my GS to stop working.

Whenever I use the new uImage, the launcher doesn’t load (I see the 2 Clockwork splash screens and then just black screen). But whenever I revert to the original uImage, the GS loads successfully (the 2 splash screens, the CPI terminal screen, then finally the launcher).

I tried downloading the new uImage twice but both has the same results. Any idea as to why this is happening?

#30

Which launcher version do you have?

#31

It says stable 1.21

#32

I just upgraded to the new ClockworkPiOS version 2.1. While USB-ETH is preconfigured, it is configured to act as a DHCP Server. If you wish your computer to act as the server to share the Internet to the GameShell, you’ll need to make a few changes. The easiest solution is to rename the files:

     /etc/default/isc-dhcp-server  to  /etc/default/isc-dhcp-server.bak
     /etc/dhcp/dhcpd.conf          to  /etc/dhcp/dhcpd.conf.bak

then edit /etc/network/interfaces to change the network configuration. I left it static to assure that the IP address remains the same. This is the configuration to share the Internet from a Mac:

     iface usb0 inet static
             address 192.168.2.2
             netmask 255.255.255.0
             gateway 192.168.2.1
             dns-nameservers 192.168.2.1

Unfortunately, the changes to the TinyCloud app in Launcher doesn’t check the address of USB-ETH, but displays a static string set in the python app itself! Rather than fixing the issue, I chose to simply replace the string in the app located at ~/launcher/Menu/GameShell/98_TinyCloud/__init__.py, replacing the line:

              [ "usb-eth-addr" , "192.168.10.1" , self._ListFontObj, self._URLColor]]

with:

              [ "usb-eth-addr" , "192.168.2.2" , self._ListFontObj, self._URLColor]]

Restart your GameShell and you’re back in business!

1 Like
#33

I’ve install HoRNDIS on mac, but the clockworkpi still can’t connect to the network through the settings on the clockworkpi, weirdly. anybody help?

#34

Hey all just wanted to say that on my Kubuntu 18.10 install, it all just worked! All I had to do was plug in a USB table and attach my clockwork pi and everything happened automatically!

#35

谢谢您的答复。

请问能不能详细说明一下osx系统下如何用usb链接game shell?
我按照你的办法做了,但后续要干什么我还不清楚。
谢谢!

Thank you for your reply.

Can you elaborate on how to use the usb link game shell under the osx system? I did it according to your method, but I still don’t know what to do next. Thank you!

#36

If you followed the above setup, and installed HoRNDIS on your Mac, your next steps would be accomplished in your System Preferences on your Mac. Go to the Sharing Preferences, and select Internet Sharing (Don’t turn it on yet!). Set Share your connection from to Wi-Fi or Ethernet, depending on which your computer is using for your network. Then check RNDIS/Ethernet Gadget in the lower box. Now turn it on with the checkmark and confirm by clicking the Start button.

Now go to the Network Preferences. Select the RNDIS settings. Configure IPv4 as Manually, IP Address: 192.168.2.10, Subnet Mask: 255.255.255.0, Router: 192.168.2.1 and then click Apply.

Now when you connect your GameShell to your Mac, it will have full access to the Internet through your computer. You should be able to SSH to your GameShell with the command:

ssh cpi@192.168.2.2
1 Like
#37

f非常感谢您的指导,按照您的说法我解决了链接问题,谢谢你!比心:)

ps.还想问问,是不是我用这样的方式链接GS之后,是不是电脑就没办法链接互联网了?

Thank you very much for your guidance. I solved the link problem according to your statement. Thank you! Contrast :slight_smile:

ps. Also want to ask, is it that I use this way to link GS, is there a way to link the Internet?

#38

抱歉又要打扰你了,我真的是对这个一窍不通。

目前我已经可以通过usb链接GS了,但是我以为这跟Windows一样,可以把GS当作一个存储来拷贝游戏跟文件。

我该如何在osx下,通过USB传输游戏?谢谢,不知道我描述的是否清楚。

Sorry to bother you again, I really don’t know anything about this.

Currently I can link GS via usb, but I thought this is the same as Windows, you can use GS as a storage to copy games and files.

How do I transfer games via USB under osx? Thank you, I don’t know if I described it clearly.

#39

If you setup Internet Sharing to the RNDIS then your GameShell has access to the Internet. To transfer files, all you need to do is select clockworkpi in the Shared list in Finder. It will request User Name & Password; Enter cpi for both. This will give you access to both the games and music folders.

1 Like
#40

每一步我都确实按照您说的操作,但是finder里面却看不到clockworkpi。。。我之前也疑惑了很久。。。

我再检查一遍到底是哪里有问题。

谢谢您!

Every step I did follow the instructions you said, but the finder does not see clockworkpi. . .

I will check again and there is a problem.

Thank you!