What a mess with clockpi A06

I received at the same time clockpi A06 and raspi 5 . I was able very fast to use kali linux and dragon OS radio suite on raspi5 .
It is impossible to do think on A06 . I have to patch but I have unknown errors . I tried to use the A06 image . I can’t make a sudo apt-get update because I have an invalid KEY .
I tried to installtinyvnc , It can’t run

What a mess …

sorry - I suggest you buy the cm4lite adapter and third party purchase a cm4 lite processor with 4G memory wifi but not emmc … I’ve been very happy with the cm4 performance - I may convert my A-06 devterm over to cm4 as a result…

I wouldn’t. I have the CM4 and when installed in the uConsole it also requires patching an old kernel to boot and address the display. There are users in the Discord working on getting other kernels and distros working, but we’re all amateurs to varying degrees.

The hardware’s cool but the software’s very much DIY. If you’re not an aspiring kernel developer, I’d recommend using the default distros for now?

Are you using standard build or custom? - my recommendation is based on the standard Clockwork distribution - should have been more exact - I’m seeing issues with the A-06 with the Clockwork image on the A-06 Devterm (screen going to sleep and not recovering) - I did not understand the discussion was a custom build (kali linux and Dragon OS should have been a clue)

I tried compiling a kernel myself but my first attempt wasn’t successful. I’m currently using the XFCE build (based on Raspberry Pi OS Lite) that ClockworkPi provided.

which processor are you working with? I’ve got the R-01 and CM4 running didn’t bother with the A-06 since I’ve had issues with that processor on the DevTerm.

CM4, which is why I mentioned the Raspberry Pi OS Lite-based distro.

can you post your apt-get output, this is less of an issue with the a06, and just silly apt shenanigans. Thats how it goes in the oss world

With standard linux , first command line are
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

With original clockpi A06 image here is the result , apt-get update can’t be done

sudo apt-get update
Hit:2 http://ports.ubuntu.com jammy InRelease
Hit:3 Index of /saiarcot895/chromium-beta/ubuntu jammy InRelease
Get:4 Index of /mozillateam/ppa/ubuntu jammy InRelease [23.8 kB]
Get:5 http://ports.ubuntu.com jammy-security InRelease [110 kB]
Get:8 Index of /oibaf/graphics-drivers/ubuntu jammy InRelease [23.9 kB]
Get:9 https://raw.githubusercontent.com/clockworkpi/apt/main/debian stable InRelease [5,408 B]
Get:11 http://ports.ubuntu.com jammy-updates InRelease [119 kB]
Get:1 https://cli.github.com/packages stable InRelease [3,917 B]
Hit:12 http://ports.ubuntu.com jammy-backports InRelease
Hit:6 https://paulcarroty.gitlab.io/vscodium-deb-rpm-repo/debs vscodium InRelease
Get:7 https://box64.debian.ryanfortner.dev/debian ./ InRelease [2,115 B]
Hit:10 Index of /apt/ jammy InRelease
Get:13 Index of /mozillateam/ppa/ubuntu jammy/main armhf Packages [42.9 kB]
Get:14 Index of /mozillateam/ppa/ubuntu jammy/main arm64 Packages [42.9 kB]
Get:15 Index of /oibaf/graphics-drivers/ubuntu jammy/main armhf Packages [15.8 kB]
Get:16 Index of /oibaf/graphics-drivers/ubuntu jammy/main arm64 Packages [15.5 kB]
Get:17 http://ports.ubuntu.com jammy-security/main arm64 Packages [1,223 kB]
Err:1 https://cli.github.com/packages stable InRelease
The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 23F3D4EA75716059
Get:18 http://ports.ubuntu.com jammy-security/universe arm64 Packages [993 kB]
Get:19 https://box64.debian.ryanfortner.dev/debian ./ Packages [3,620 B]
Get:20 http://ports.ubuntu.com jammy-security/universe armhf Packages [736 kB]
Get:21 http://ports.ubuntu.com jammy-security/main armhf Packages [701 kB]
Get:22 http://ports.ubuntu.com jammy-security/restricted arm64 Packages [1,212 kB]
Get:23 http://ports.ubuntu.com jammy-updates/main armhf Packages [965 kB]
Get:24 http://ports.ubuntu.com jammy-updates/main arm64 Packages [1,494 kB]
Get:25 http://ports.ubuntu.com jammy-updates/universe arm64 Packages [1,262 kB]
Get:26 http://ports.ubuntu.com jammy-updates/universe armhf Packages [1,001 kB]
Get:27 http://ports.ubuntu.com jammy-updates/restricted arm64 Packages [1,231 kB]
Ign:28 http://deb.volian.org/volian scar InRelease
Ign:28 http://deb.volian.org/volian scar InRelease
Ign:28 http://deb.volian.org/volian scar InRelease
Err:28 http://deb.volian.org/volian scar InRelease
Could not connect to deb.volian.org:80 (, connection timed out
Fetched 11.2 MB in 38s (298 kB/s)
Reading package lists… Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://cli.github.com/packages stable InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 23F3D4EA75716059
W: Failed to fetch http://cli.github.com/packages/dists/stable/InRelease The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 23F3D4EA75716059
W: Failed to fetch http://deb.volian.org/volian/dists/scar/InRelease Could not connect to deb.volian.org:80 (, connection timed out
W: Some index files failed to download. They have been ignored, or old ones used instead.

that last error was on the side of volian. it works now.
the github cli one can be ignored for most users, but to fix it:

wget https://cli.github.com/packages/githubcli-archive-keyring.gpg
sudo mv githubcli-archive-keyring.gpg /usr/share/keyrings/githubcli.gpg

expired keys are sure annoying, but not the fault of clockworkpi.
what is a more annoying is the patchy documentation on literally anything…

1 Like

Thanks it is working fine

That greatly discourage me from joining the game ! I’m from Pi 4 so I know how it performs, and want to get something similar with everything out of the box. I initially planned to pickup the uConsole to replace my tablet, as it got the 4G module. I first decided to get the emmc CM4 as I do not trust uSD, I’ve got some bad cards from cell phone use. But the emmc CM4 got only 32G so that I changed my mind, and planned to go for the CM4 without emmc but with 8G of RAM, more memory hopefully reduce r/w to the card to extend it’s life. I read on the Raspberry website there’s a CM4 with 8G of RAM w/o emmc (CM4008000), and in here there’s A-06 with 4G of RAM, but on other post some said he got the A-06 with 8G I’m confused, is there a hidden menu on the ordering page we don’t normally see ? and how long the A-06 has been released, how come it still not well supported, I read many comments on setting up the A-06 was a pain. I will not do crazy things with the device, I just want a small working mobile computer for daily use, and I can’t find any alternatives can fit the bill.

I have the CM4 with 4GB - it runs webpages, discord, spyder ide, even visual studio (code) email and open office - some have even ran a Software Defined Radio receiver on it… which is very processor heavy… I would not get a CM4 with less than 4GB - i went non EMMC memory since it won’t boot from the main board SD card and you will have to flash the EMMC with the OS… I use a 64GB card I believe up to 250GB will work - I’ve already corrupted some programs and had to reload - so keep a build log and back up the image occasionally …

As far as I know, we’re the only hobby platform running the A-06. Since clockwork is a niche within a niche, there’s practically zero support.

1 Like

That’s why I purchased two Cm4 adapter boards - I intend to convert my DevTerm over to CM4… using the stock image from Clockwork… the A-06 has an issue with screen lock up on sleep…

Yea, none of these chips actually do sleep properly. It’s not a thing for these chips. The pi can fake it better though.